Section 4
- natm · Native Mode ATM protocol layer
- natmip · IP over ATM PVCs
- ncr · NCR 53C8xx SCSI driver
- ncv · NCR 53C500 based SCSI host adapter driver
- nda · NVMe Direct Access device driver
- ndis · NDIS miniport driver wrapper
- ne · NE2000 and compatible 10/100 Ethernet device
- necsb · NEC PC-9801-86 sound board
- neo · NeoMagic 256AV/ZX audio device
- neomagic · Neomagic video driver
- nep · Sun Neptune 10Gb Ethernet device
- net · introduction to networking facilities
- net80211 · standard interface to IEEE 802.11 devices
- netdump · protocol for transmitting kernel dumps to a remote server
- netfpga10g_nf10bmac · driver for the NetFPGA-10G Embedded CPU Ethernet Core
- netgdb · protocol for debugging the kernel with GDB over the network
- netgraph · graph based kernel networking subsystem
- netintro · introduction to networking facilities
- netlink · Kernel network configuration protocol
- netmap · a framework for fast packet I/O
- netrom · NET/ROM amateur packet radio protocol family
- netwave_cs · Xircom Creditcard Netwave device driver
- networking · introduction to networking facilities
- newport · Newport video driver
- nfe · NVIDIA nForce MCP Ethernet driver
- nfslockd · NFS advisory locking
- nfsmb · NVIDIA nForce2/3/4 SMBus 2.0 controller driver
- nfsv4 · NFS Version 4 Protocol
- ng_async · asynchronous framing netgraph node type
- ng_atm · netgraph ATM node type
- ng_atmllc · ATM LLC netgraph node type
- ng_atmpif · netgraph HARP/ATM Virtual Physical Interface
- ng_bluetooth · placeholder for global Bluetooth variables
- ng_bpf · Berkeley packet filter netgraph node type
- ng_bridge · Ethernet bridging netgraph node type
- ng_bt3c · Netgraph node type that is also a 3Com Bluetooth PC card driver
- ng_btsocket · Bluetooth sockets layer
- ng_car · Committed Access Rate netgraph node
- ng_ccatm · ATM Call Control netgraph node type
- ng_checksum · IPv4/TCP/UDP checksum reconstructing netgraph node
- ng_cisco · Cisco HDLC protocol netgraph node type
- ng_deflate · RFC 1979 Deflate PPP compression netgraph node
- ng_device · device netgraph node type
- ng_echo · netgraph echo node type
- ng_eiface · generic Ethernet interface netgraph node type
- ng_etf · Ethertype filtering netgraph node type
- ng_ether · Ethernet netgraph node type
- ng_ether_echo · Ethernet loopback netgraph node
- ng_fec · netgraph Fast EtherChannel node
- ng_frame_relay · frame relay netgraph node type
- ng_gif · generic tunnel interface netgraph node type
- ng_gif_demux · demultiplexer for packets from ng_gif(4) nodes
- ng_h4 · Netgraph node type that is also an H4 line discipline
- ng_hci · Netgraph node type that is also a Bluetooth Host Controller Interface (HCI) layer
- ng_hole · netgraph discard node type
- ng_hub · packet distribution netgraph node type
- ng_iface · interface netgraph node type
- ng_ip_input · netgraph IP input node type
- ng_ipfw · interface between netgraph and IP firewall
- ng_ksocket · kernel socket netgraph node type
- ng_l2cap · Netgraph node type that implements Bluetooth Logical Link Control and Adaptation Protocol (L2CAP)
- ng_l2tp · L2TP protocol netgraph node type
- ng_lmi · frame relay LMI protocol netgraph node type
- ng_macfilter · Ethernet MAC address based packet filtering netgraph node
- ng_mppc · Microsoft MPPC/MPPE compression and encryption netgraph node type
- ng_nat · NAT netgraph node type
- ng_netflow · Cisco's NetFlow implementation
- ng_one2many · packet multiplexing netgraph node type
- ng_patch · trivial mbuf data modifying netgraph node
- ng_pipe · traffic manipulating netgraph node
- ng_ppp · PPP protocol netgraph node type
- ng_pppoe · RFC 2516 PPPoE protocol netgraph node type
- ng_pptpgre · PPTP GRE protocol netgraph node type
- ng_pred1 · RFC 1978 Predictor-1 PPP compression netgraph node
- ng_rfc1490 · RFC 1490 netgraph node type
- ng_socket · netgraph socket node type
- ng_source · netgraph node for traffic generation
- ng_split · netgraph node to separate incoming and outgoing flows
- ng_sppp · sppp netgraph node type
- ng_sscfu · netgraph SSCF at the UNI node type
- ng_sscop · netgraph SSCOP node type
- ng_tag · mbuf tags manipulating netgraph node
- ng_tcpmss · netgraph node to adjust TCP MSS option
- ng_tee · netgraph ``tee'' node type
- ng_tty · netgraph node type that is also a line discipline
- ng_ubt · Netgraph node type that is also a driver for Bluetooth USB devices
- ng_UI · UI netgraph node type
- ng_uni · netgraph UNI node type
- ng_vjc · Van Jacobson compression netgraph node type
- ng_vlan · IEEE 802.1Q VLAN tagging netgraph node type
- ng_vlan_rotate · IEEE 802.1ad VLAN manipulation netgraph node
- ngatmbase · netgraph ATM utility module
- ngbe · WangXun WX1860 PCI Express 10/100/1Gb Ethernet device
- nge · National Semiconductor PCI Gigabit Ethernet adapter driver
- nhi · USB4 host interface
- nlsysevent · Netlink-based kernel event notification module
- nmdm · nullmodem terminal driver
- nmea · NMEA 0183 timedelta sensor
- nouveau · NVIDIA video driver
- npx · Numeric Processing Extension coprocessor
- nsc · Nsc video driver
- nsclpcsio · National Semiconductor PC87366 LPC Super I/O with GPIO
- nsgphy · National Semiconductor DP83891/DP83861/DP83865 10/100/1Gb Ethernet PHY
- nsp · Workbit Ninja SCSI-3 based PC-Card SCSI host adapter driver
- nsphy · National Semiconductor DP83840 10/100 Ethernet PHY
- nsphyter · National Semiconductor DP83815/DP83843/DP83847 10/100 Ethernet PHY
- ntb · Non-Transparent Bridge subsystem
- ntb_hw_amd · AMD Non-Transparent Bridge driver
- ntb_hw_intel · Intel Non-Transparent Bridge driver
- ntb_hw_plx · PLX/Avago/Broadcom Non-Transparent Bridge driver
- ntb_transport · Packet-oriented transport for Non-Transparent Bridges
- ntsync · NT-like synchronization operations device driver
- null · data sink
- nullfs · null file system
- numa · Non-Uniform Memory Access
- nv · NVIDIA video driver
- nvd · NVM Express disk driver
- nvdimm · ACPI NVDIMM driver
- nve · NVIDIA nForce MCP Networking Adapter device driver
- nviic · NVIDIA nForce2/3/4 SMBus controller
- nvme · NVM Express core driver
- nvmf · NVM Express over Fabrics host driver
- nvmf_che · TCP transport for NVM Express over Fabrics on Chelsio NICs
- nvmf_tcp · TCP transport for NVM Express over Fabrics
- nvmft · NVM Express over Fabrics CAM Target Layer frontend
- nvram · non-volatile RAM
- nvt · Nuvoton W83795G/ADG temperature, voltage, and fan sensor