---
name: "snmptraplogd"
section: "8"
platform: "linux"
package: "snmptraplogd"
version: "1.0-6.1"
release: "Debian 2.2 (Potato)"
platforms: ["linux"]
url: "https://new.carta.tech/snmptraplogd"
---

# snmptraplogd(8)

Receive and log snmp trap messages.

## NAME

snmptraplogd - Receive and log snmp trap messages.

## SYNOPSIS

snmptraplogd \[ -v 1 \] \[ -s \] \[-f cfgfile\]

## DESCRIPTION

Snmptraplogd is an SNMP application that receives and logs snmp trap messages sent to the SNMP-TRAP port (162) on the local machine. The output of the daemon may be specified via a configuration file.

The option **-v 1** should be specified to receive and log V1 traps (eg. sent by  **[snmptrap(1)](/snmptrap/1.md)** ).\
 Remark: this option is a dummy. V1 traps are the default.

The option **-s** is completely ignored!

Adding a "-d" to the argument list will cause the application to dump input and output packets.

If the option **-f cfgfile** is given, the output of the daemon is configured via the mentioned configuration file. If this option is not specified, a default output format is used.

The syntax of the configuration file is explained in **/usr/doc/snmptraplogd/snmptrapdlog.conf** !

*Snmptraplogd* must be run as root so that UDP port 162 can be opened.

## SEE ALSO

syslog(8), [variables(5)](/variables/5.md), RFC 1155, RFC 1156, RFC 1157, SNMP Security Internet Drafts
