---
name: "snmptrapfmt"
section: "8"
platform: "linux"
package: "snmptrapfmt"
version: "1.19"
release: "Debian 13 (Trixie)"
platforms: ["linux"]
url: "https://new.carta.tech/snmptrapfmt"
---

# snmptrapfmt(8)

Receive and log SNMP trap messages from a trap handler.

## NAME

snmptrapfmt - Receive and log SNMP trap messages from a trap handler.

## SYNOPSIS

snmptrapfmt \[-d num\] \[-D\] \[-f cfgfile\]

## DESCRIPTION

Snmptrapfmt receives SNMP trap data through a local pipe. The trap data is written to this pipe by a SNMP trap handler which is called by  **snmptrapd** (configuration is done in /etc/snmp/snmptrapd.conf) during the installation if this package. Snmptrapfmt formats the received trap data according to the specifications in the configuration file /etc/snmp/snmptrapfmt.conf (see this file for the syntax). The output of the snmptrapfmt application may be written to a log file or forwarded to the syslog daemon.

The option **-d 1** should be specified to enable tracing. Trace information is then written to the file /var/tmp/snmptrapfmt.trc.

If the option **-f cfgfile** is given, the output of the daemon is configured via the mentioned configuration file. If this option is not specified, a default output format is used.

If the option **-D** is given, the the program will daemonize into the background.

The syntax of the configuration file is explained in **/etc/snmp/snmptrapfmt.conf** !

## FILES

**/etc/init.d/snmptrapfmt** is the start/stop script.

**/etc/snmp/snmptrapfmt.conf** is the configuration file.

**/var/run/snmptrapfmt.pid** is the PID file.

**/etc/snmp/snmptrapd.conf** is the configuration file of the snmptrapd daemon, which calls the trap handler snmptrapfmthdlr.

**/usr/sbin/snmptrapfmt** is the executable of the application.

**/usr/sbin/snmptrapfmthdlr** is the executable of the trap handler.

**/var/run/snmptrapfmt.p** is the communication pipe between the trap handler snmptrapfmthdlr and the  formatter snmptrapfmt.

**/var/tmp/snmptrapfmt.trc** is the trace file if the option -d is specified.

**/var/log/snmptrapfmt.log** is the log file as specified in the configuration file.

## SEE ALSO

[snmptrapfmthdlr(8)](/snmptrapfmthdlr/8.md), syslog(8), [variables(5)](/variables/5.md), RFC 1155, RFC 1156, RFC 1157, SNMP Security Internet Drafts
