---
name: "snmpd_metrics"
section: "8"
platform: "openbsd"
package: "man"
version: "8.0-current-20261101"
release: "OpenBSD 8.0-current (2026-11-01)"
platforms: ["openbsd"]
url: "https://new.carta.tech/snmpd_metrics"
---

# snmpd\_metrics(8)

export snmpd MIB data

## NAME

**snmpd\_metrics** – export snmpd MIB data

## SYNOPSIS

**snmpd\_metrics** \[**-dv**\] \[**-C** *option*\] \[**-c** *context*\] \[**-s** *path*\]

## DESCRIPTION

**snmpd\_metrics** exports the following (partial) MIBs via an AgentX compatible (snmp) daemon: HOST-RESOURCES-MIB, IF-MIB, OPENBSD-PF-MIB, OPENBSD-SENSORS-MIB, OPENBSD-CARP-MIB, OPENBSD-MEM-MIB, IP-MIB, IP-FORWARD-MIB, UCD-DISKIO-MIB, and BRIDGE-MIB.

The options are as follows:

- **-C** *option*

  Enable MIB-specific options. Currently only **filter-routes** is supported. If set ask the kernel to filter route update messages on the routing socket. Routing table information will not be available, but CPU use will be reduced during bulk updates.

- **-c** *context*

  The SNMPv3 context and can usually be omitted.

- **-d**

  Do not daemonize and log to *stderr*.

- **-s** *path*

  Connect to the AgentX master via *path*. It defaults to */var/agentx/master*.

- **-v**

  Produce more verbose output.

## SEE ALSO

[snmp(1)](/snmp/1.md), [snmpd(8)](/snmpd/8.md)

## STANDARDS

P. Grillo and WeSync.com, *Host Resources MIB*, RFC 2790, March 2000.

K. McCloghrie, Cisco Systems, F. Kastenholz, and Argon Networks, *The Interfaces Group MIB*, RFC 2863, June 2000.

S. Routhier, Ed., *Management Information Base for the Internet Protocol (IP)*, RFC 4293, April 2006.

B. Haberman and Johns Hopkins University, *IP Forwarding Table MIB*, RFC 4292, April 2006.

K. Norseth, Ed., L-3 Communications, E. Bell, Ed., and 3Com Europe Limited, *Definitions of Managed Objects for Bridges*, RFC 4188, September 2005.

## AUTHORS

Martijn van Duren ⟨*martijn@openbsd.org*⟩ Joel Knight ⟨*joel@openbsd.org*⟩ Reyk Floeter ⟨*reyk@openbsd.org*⟩
