---
name: "smailqual"
section: "5"
platform: "linux"
package: "smail"
version: "3.2.0.115-7.1"
release: "Debian 4.0 (Etch)"
platforms: ["linux"]
url: "https://new.carta.tech/smailqual"
---

# smailqual(5)

smail hostname qualification configuration

## NAME

/etc/smail/qualify - smail hostname qualification configuration

## THE QUALIFY FILE

This section details the format and use of the hostname qualification file.

The qualify file defines the domain *name*(s) to be used in making all hostnames fully-qualified. Note that this file is used only for bare hostnames, i.e. names without dots.

The qualify file uses the standard routine for reading file entries.  Each entry should have the form:

```
    hostname    domain
```

stating that the host name *hostname* should be considered a part of domain *domain*. As a special case, if the *hostname* value is the special string \`\`\*'', the entry matches any host.  This is a catch-all feature which should only be used in the last entry in a qualify file.  Typically, UUCP sites should should have an entry like:

```
    *   uucp
```

at the end of the qualify file.

If the qualify file is missing, or if no entry is found that matches a given hostname, then no hostname qualification is performed.

## FILES

Hostname qualifications.

## SEE ALSO

[*smailconf*(5)](/smailconf/5.md), [*smaildrct*(5)](/smaildrct/5.md), [*smailrtrs*(5)](/smailrtrs/5.md), [*smailrtry*(5)](/smailrtry/5.md), [*smailtrns*(5)](/smailtrns/5.md), [*smail*(8)](/smail/8.md). *Smail Administration and Installation Guide*. DARPA Internet Requests for Comments RFC 821, RFC 822, RFC 974, RFC 976, and RFC 1123.

## BUGS

Colons cannot be included in the value of a list element. Database files cannot contain \`\`#'' in the left-hand field.

## COPYRIGHT

*Copyright* (C) 1987, 1988 Ronald S. Karr and Landon Curt Noll\
 *Copyright* (C) 1992 Ronald S. Karr See a file *COPYING*, distributed with the source code, or type *smail -bc*, to view distribution rights and restrictions associated with this software.
