---
name: "smailmeth"
section: "5"
platform: "linux"
package: "smail"
version: "3.2.0.115-7.1"
release: "Debian 4.0 (Etch)"
platforms: ["linux"]
url: "https://new.carta.tech/smailmeth"
---

# smailmeth(5)

smail host specific transports configuration

## NAME

/etc/smail/methods/ - smail host specific transports configuration

## METHOD FILES

Method files define a relation between a set of hostnames and a set of transports to be used in delivering to those hostnames. Method files use the standard routine for reading file entries, just as with the *config*, *directors*, *routers*, and *transports* files.  Each entry should have the form:

```
    hostname transport-name
```

stating that mail being sent to *hostname* should be delivered using the transport *transport-name*. As a special case, if the *hostname* value is the special string \`\`\*'', the entry matches any host.  This is a catch-all feature which should only be used in the last entry in a method file.

Entries in a method file can be associated with particular message grades.  This allows different grades to use different transports, such as non-demand UUCP for messages with a bulk or junk precedence.  Grade ranges are specified by appending a grade letter range to the hostname, separated by a slash (\`\`/'').  Entries with grades can be in any of the forms:

```
    hostname>/X     transport-name
    hostname>/X-*   transport-name
    hostname>/*-Y   transport-name
    hostname>/X-Y   transport-name
```

See the definition of the **grades** configuration variable for a discussion of grade letters, and their correlation with message precedence strings.  In the first form, the transport is used for an exact match of the grade letter.  In the second form, a match requires a grade a character value of at least X.  In the third, form a match requires a grade character value of at most Y.  The final form specifies a range of grades from character value X to character value Y.

For example, with the default value for the **grades** variable, the following file will use smtp for hosts **local1** and **local2**, if the precedence is air-mail or better; otherwise, for any host with a precedence of first-class or better, demand-polled uucp is used; otherwise, queued uucp is used:

```
    local1/*-A  smtp
    local2/*-A  smtp
    */*-C       demand_uucp
    *           uucp
```

## FILES

Smail host specific transports configuration files.

## SEE ALSO

[*smailconf*(5)](/smailconf/5.md), [*smaildrct*(5)](/smaildrct/5.md), [*smailqual*(5)](/smailqual/5.md), [*smailrtrs*(5)](/smailrtrs/5.md), [*smailrtry*(5)](/smailrtry/5.md), [*smailtrns*(5)](/smailtrns/5.md), [*smail*(8)](/smail/8.md). *Smail Administration and Installation Guide*. DARPA Internet Requests for Comments: RFC 821, RFC 822, RFC 974, RFC 976, and RFC 1123.

## BUGS

Colons cannot be included in the value of a list element. Database files cannot contain \`\`#'' in the left-hand field.

## COPYRIGHT

*Copyright* (C) 1987, 1988 Ronald S. Karr and Landon Curt Noll *Copyright* (C) 1992 Ronald S. Karr See a file *COPYING*, distributed with the source code, or type *smail -bc* to view distribution rights and restrictions associated with this software.
