---
name: "slaacd"
section: "8"
platform: "openbsd"
package: "man"
version: "8.0-current-20261101"
release: "OpenBSD 8.0-current (2026-11-01)"
platforms: ["openbsd"]
url: "https://new.carta.tech/slaacd"
---

# slaacd(8)

Stateless Address Autoconfiguration (SLAAC) daemon

## NAME

**slaacd** – Stateless Address Autoconfiguration (SLAAC) daemon

## SYNOPSIS

**slaacd** \[**-dv**\] \[**-s** *socket*\]

## DESCRIPTION

**slaacd** is a stateless address autoconfiguration (SLAAC) daemon for clients. If an interface has the **AUTOCONF6** flag set (auto configuration is enabled), **slaacd** regularly sends out requests for IPv6 router advertisement messages, such as those sent by [rad(8)](/rad/8.md), and uses those messages to configure the relevant interface.

See [hostname.if(5)](/hostname.if/5.md) and [ifconfig(8)](/ifconfig/8.md) on how to enable auto configuration on an interface.

**slaacd** monitors network interface states (interface going up or down, auto configuration enabled or disabled, etc.) and sends router solicitations when necessary. A running **slaacd** can be controlled with the [slaacctl(8)](/slaacctl/8.md) utility.

The options are as follows:

- **-d**

  Do not daemonize. If this option is specified, **slaacd** will run in the foreground and log to *stderr*.

- **-s** *socket*

  Use an alternate location for the default control socket.

- **-v**

  Produce more verbose output. Multiple **-v** options increase the verbosity.

## FILES

- */dev/slaacd.sock*

  UNIX-domain socket used for communication with [slaacctl(8)](/slaacctl/8.md).

## SEE ALSO

[hostname.if(5)](/hostname.if/5.md), [ifconfig(8)](/ifconfig/8.md), [rad(8)](/rad/8.md), [slaacctl(8)](/slaacctl/8.md)

## STANDARDS

R. Draves and D. Thaler, *Default Router Preferences and More-Specific Routes*, RFC 4191, November 2005.

R. Hinden and S. Deering, *IP Version 6 Addressing Architecture*, RFC 4291, February 2006.

T. Narten, E. Nordmark, W. Simpson, and H. Soliman, *Neighbor Discovery for IP version 6 (IPv6)*, RFC 4861, September 2007.

F. Gont, *A Method for Generating Semantically Opaque Interface Identifiers with IPv6 Stateless Address Autoconfiguration (SLAAC)*, RFC 7217, April 2014.

A. Yourtchenko and L. Colitti, *Reducing Energy Consumption of Router Advertisements*, RFC 7772, February 2016.

F. Gont, A. Cooper, D. Thaler, and W. Liu, *Recommendation on Stable IPv6 Interface Identifiers*, RFC 8064, February 2017.

J. Jeong, S. Park, L. Beloeil, and S. Madanapalli, *IPv6 Router Advertisement Options for DNS Configuration*, RFC 8106, March 2017.

F. Gont, S. Krishnan, T. Narten, and R. Draves, *Temporary Address Extensions for Stateless Address Autoconfiguration in IPv6*, RFC 8981, February 2021.

## HISTORY

The **slaacd** program first appeared in OpenBSD 6.2.

## AUTHORS

The **slaacd** program was written by Florian Obser ⟨*florian@openbsd.org*⟩.
