---
name: "rte_mtr_capabilities"
section: "3"
platform: "linux"
package: "dpdk-doc"
version: "24.11.4-0+deb13u1"
release: "Debian 13 (Trixie)"
platforms: ["linux"]
url: "https://new.carta.tech/rte_mtr_capabilities"
---

# rte\_mtr\_capabilities(3)

## NAME

rte\_mtr\_capabilities

## SYNOPSIS

`#include <rte_mtr.h>`

### Data Fields

uint32\_t **n\_max**\
 uint32\_t **n\_shared\_max**\
 int **identical**\
 int **shared\_identical**\
 uint32\_t **shared\_n\_flows\_per\_mtr\_max**\
 uint32\_t **chaining\_n\_mtrs\_per\_flow\_max**\
 int **chaining\_use\_prev\_mtr\_color\_supported**\
 int **chaining\_use\_prev\_mtr\_color\_enforced**\
 uint32\_t **meter\_srtcm\_rfc2697\_n\_max**\
 uint32\_t **meter\_trtcm\_rfc2698\_n\_max**\
 uint32\_t **meter\_trtcm\_rfc4115\_n\_max**\
 uint64\_t **meter\_rate\_max**\
 uint64\_t **meter\_policy\_n\_max**\
 int **color\_aware\_srtcm\_rfc2697\_supported**\
 int **color\_aware\_trtcm\_rfc2698\_supported**\
 int **color\_aware\_trtcm\_rfc4115\_supported**\
 int **srtcm\_rfc2697\_byte\_mode\_supported**\
 int **srtcm\_rfc2697\_packet\_mode\_supported**\
 int **trtcm\_rfc2698\_byte\_mode\_supported**\
 int **trtcm\_rfc2698\_packet\_mode\_supported**\
 int **trtcm\_rfc4115\_byte\_mode\_supported**\
 int **trtcm\_rfc4115\_packet\_mode\_supported**\
 uint64\_t **stats\_mask**\
 uint64\_t **input\_color\_proto\_mask**\
 int **separate\_input\_color\_table\_per\_port**\

## Detailed Description

MTR capabilities

Definition at line **356** of file **rte\_mtr.h**.

## Field Documentation

### uint32\_t n\_max

Maximum number of MTR objects.

Definition at line **358** of file **rte\_mtr.h**.

### uint32\_t n\_shared\_max

Maximum number of MTR objects that can be shared by multiple flows. The value of zero indicates that shared MTR objects are not supported. The maximum value is *n\_max*.

Definition at line **364** of file **rte\_mtr.h**.

### int identical

When non-zero, this flag indicates that all the MTR objects that cannot be shared by multiple flows have identical capability set.

Definition at line **369** of file **rte\_mtr.h**.

### int shared\_identical

When non-zero, this flag indicates that all the MTR objects that can be shared by multiple flows have identical capability set.

Definition at line **374** of file **rte\_mtr.h**.

### uint32\_t shared\_n\_flows\_per\_mtr\_max

Maximum number of flows that can share the same MTR object. The value of zero is invalid. The value of 1 means that shared MTR objects not supported.

Definition at line **380** of file **rte\_mtr.h**.

### uint32\_t chaining\_n\_mtrs\_per\_flow\_max

Maximum number of MTR objects that can be part of the same flow. The value of zero is invalid. The value of 1 indicates that MTR object chaining is not supported. The maximum value is *n\_max*.

Definition at line **386** of file **rte\_mtr.h**.

### int chaining\_use\_prev\_mtr\_color\_supported

When non-zero, it indicates that the packet color identified by one MTR object can be used as the packet input color by any subsequent MTR object from the same flow. When zero, it indicates that the color determined by one MTR object is always ignored by any subsequent MTR object from the same flow. Only valid when MTR chaining is supported, i.e. *chaining\_n\_mtrs\_per\_flow\_max* is greater than 1. When non-zero, it also means that the color aware mode is supported by at least one metering algorithm.

Definition at line **398** of file **rte\_mtr.h**.

### int chaining\_use\_prev\_mtr\_color\_enforced

When non-zero, it indicates that the packet color identified by one MTR object is always used as the packet input color by any subsequent MTR object that is part of the same flow. When zero, it indicates that whether the color determined by one MTR object is either ignored or used as the packet input color by any subsequent MTR object from the same flow is individually configurable for each MTR object. Only valid when *chaining\_use\_prev\_mtr\_color\_supported* is non-zero.

Definition at line **409** of file **rte\_mtr.h**.

### uint32\_t meter\_srtcm\_rfc2697\_n\_max

Maximum number of MTR objects that can have their meter configured to run the srTCM RFC 2697 algorithm. The value of 0 indicates this metering algorithm is not supported. The maximum value is *n\_max*.

Definition at line **415** of file **rte\_mtr.h**.

### uint32\_t meter\_trtcm\_rfc2698\_n\_max

Maximum number of MTR objects that can have their meter configured to run the trTCM RFC 2698 algorithm. The value of 0 indicates this metering algorithm is not supported. The maximum value is *n\_max*.

Definition at line **421** of file **rte\_mtr.h**.

### uint32\_t meter\_trtcm\_rfc4115\_n\_max

Maximum number of MTR objects that can have their meter configured to run the trTCM RFC 4115 algorithm. The value of 0 indicates this metering algorithm is not supported. The maximum value is *n\_max*.

Definition at line **427** of file **rte\_mtr.h**.

### uint64\_t meter\_rate\_max

Maximum traffic rate that can be metered by a single MTR object. For srTCM RFC 2697, this is the maximum CIR rate. For trTCM RFC 2698, this is the maximum PIR rate. For trTCM RFC 4115, this is the maximum value for the sum of PIR and EIR rates.

Definition at line **434** of file **rte\_mtr.h**.

### uint64\_t meter\_policy\_n\_max

Maximum number of policy objects that can have. The value of 0 is invalid. Policy must be supported for meter. The maximum value is *n\_max*.

Definition at line **441** of file **rte\_mtr.h**.

### int color\_aware\_srtcm\_rfc2697\_supported

When non-zero, it indicates that color aware mode is supported for the srTCM RFC 2697 metering algorithm.

Definition at line **447** of file **rte\_mtr.h**.

### int color\_aware\_trtcm\_rfc2698\_supported

When non-zero, it indicates that color aware mode is supported for the trTCM RFC 2698 metering algorithm.

Definition at line **453** of file **rte\_mtr.h**.

### int color\_aware\_trtcm\_rfc4115\_supported

When non-zero, it indicates that color aware mode is supported for the trTCM RFC 4115 metering algorithm.

Definition at line **459** of file **rte\_mtr.h**.

### int srtcm\_rfc2697\_byte\_mode\_supported

srTCM rfc2697 byte mode supported. When non-zero, it indicates that byte mode is supported for the srTCM RFC 2697 metering algorithm.

Definition at line **466** of file **rte\_mtr.h**.

### int srtcm\_rfc2697\_packet\_mode\_supported

srTCM rfc2697 packet mode supported. When non-zero, it indicates that packet mode is supported for the srTCM RFC 2697 metering algorithm.

Definition at line **473** of file **rte\_mtr.h**.

### int trtcm\_rfc2698\_byte\_mode\_supported

trTCM rfc2698 byte mode supported. When non-zero, it indicates that byte mode is supported for the trTCM RFC 2698 metering algorithm.

Definition at line **480** of file **rte\_mtr.h**.

### int trtcm\_rfc2698\_packet\_mode\_supported

trTCM rfc2698 packet mode supported. When non-zero, it indicates that packet mode is supported for the trTCM RFC 2698 metering algorithm.

Definition at line **487** of file **rte\_mtr.h**.

### int trtcm\_rfc4115\_byte\_mode\_supported

trTCM rfc4115 byte mode supported. When non-zero, it indicates that byte mode is supported for the trTCM RFC 4115 metering algorithm.

Definition at line **494** of file **rte\_mtr.h**.

### int trtcm\_rfc4115\_packet\_mode\_supported

trTCM rfc4115 packet mode supported. When non-zero, it indicates that packet mode is supported for the trTCM RFC 4115 metering algorithm.

Definition at line **501** of file **rte\_mtr.h**.

### uint64\_t stats\_mask

Set of supported statistics counter types.

**See also**

enum **rte\_mtr\_stats\_type**

Definition at line **506** of file **rte\_mtr.h**.

### uint64\_t input\_color\_proto\_mask

Set of supported input color protocol.

**See also**

enum **rte\_mtr\_color\_in\_protocol**

Definition at line **511** of file **rte\_mtr.h**.

### int separate\_input\_color\_table\_per\_port

When non-zero, it indicates that driver supports separate input color table for given ethdev port.

Definition at line **516** of file **rte\_mtr.h**.

## Author

Generated automatically by Doxygen for DPDK from the source code.
