---
name: "resolver"
section: "3bind"
platform: "linux"
package: "bind-dev"
version: "1:8.4.7-1"
release: "Debian 4.0 (Etch)"
platforms: ["linux"]
url: "https://new.carta.tech/resolver/3bind"
---

# resolver(3bind)

resolver routines

## NAME

**res\_ninit**, **res\_ourserver\_p**, **fp\_resstat**, **res\_hostalias**, **res\_pquery**, **res\_nquery**, **res\_nsearch**, **res\_nquerydomain**, **res\_nmkquery**, **res\_nsend**, **res\_nupdate**, **res\_nmkupdate**, **res\_nclose**, **res\_nsendsigned**, **res\_findzonecut**, **res\_getservers**, **res\_setservers**, **res\_ndestroy**, **dn\_comp**, **dn\_expand**, **hstrerror**, **res\_init**, **res\_isourserver**, **fp\_nquery**, **p\_query**, **hostalias**, **res\_query**, **res\_search**, **res\_querydomain**, **res\_mkquery**, **res\_send**, **res\_update**, **res\_close**, **herror** – resolver routines

## SYNOPSIS

**#include \<sys/types.h\>**

**#include \<netinet/in.h\>**

**#include \<arpa/nameser.h\>**

**#include \<resolv.h\>**

**#include \<res\_update.h\>**

*typedef* *struct* *\_\_res\_state* *\*res\_state*;

*int*\

**res\_ninit**(*res\_state statp*);

*int*\

**res\_ourserver\_p**(*const res\_state statp*, *const struct sockaddr\_in \*addr*);

*void*\

**fp\_resstat**(*const res\_state statp*, *FILE \*fp*);

*const char \**\

**res\_hostalias**(*const res\_state statp*, *const char \*name*, *char \*buf*, *size\_t buflen*);

*int*\

**res\_pquery**(*const res\_state statp*, *const u\_char \*msg*, *int msglen*, *FILE \*fp*);

*int*\

**res\_nquery**(*res\_state statp*, *const char \*dname*, *int class*, *int type*, *u\_char \*answer*, *int anslen*);

*int*\

**res\_nsearch**(*res\_state statp*, *const char \*dname*, *int class*, *int type*, *u\_char \* answer*, *int anslen*);

*int*\

**res\_nquerydomain**(*res\_state statp*, *const char \*name*, *const char \*domain*, *int class*, *int type*, *u\_char \*answer*, *int anslen*);

*int*\

**res\_nmkquery**(*res\_state statp*, *int op*, *const char \*dname*, *int class*, *int type*, *const u\_char \*data*, *int datalen*, *const u\_char \*newrr*, *u\_char \*buf*, *int buflen*);

*int*\

**res\_nsend**(*res\_state statp*, *const u\_char \*msg*, *int msglen*, *u\_char \*answer*, *int anslen*);

*int*\

**res\_nupdate**(*res\_state statp*, *ns\_updrec \*rrecp\_in*);

*int*\

**res\_nmkupdate**(*res\_state statp*, *ns\_updrec \*rrecp\_in*, *u\_char \*buf*, *int buflen*);

*void*\

**res\_nclose**(*res\_state statp*);

*int*\

**res\_nsendsigned**(*res\_state statp*, *const u\_char \*msg*, *int msglen*, *ns\_tsig\_key \*key*, *u\_char \*answer*, *int anslen*);

*int*\

**res\_findzonecut**(*res\_state statp*, *const char \*dname*, *ns\_class class*, *int options*, *char \*zname*, *size\_t zsize*, *struct in\_addr \*addrs*, *int naddrs*);

*int*\

**res\_getservers**(*res\_state statp*, *union res\_sockaddr\_union \*set*, *int cnt*);

*void*\

**res\_setservers**(*res\_state statp*, *const union res\_sockaddr\_union \*set*, *int cnt*);

*void*\

**res\_ndestroy**(*res\_state statp*);

*int*\

**dn\_comp**(*const char \*exp\_dn*, *u\_char \*comp\_dn*, *int length*, *u\_char \*\*dnptrs*, *u\_char \*\*lastdnptr*);

*int*\

**dn\_expand**(*const u\_char \*msg*, *const u\_char \*eomorig*, *const u\_char \*comp\_dn*, *char \*exp\_dn*, *int  length*);

*const char \**\

**hstrerror**(*int err*);

### DEPRECATED

**#include \<sys/types.h\>**

**#include \<netinet/in.h\>**

**#include \<arpa/nameser.h\>**

**#include \<resolv.h\>**

**#include \<res\_update.h\>**

*int*\

**res\_init**(*void*);

*int*\

**res\_isourserver**(*const struct sockaddr\_in \*addr*);

*int*\

**fp\_nquery**(*const u\_char \*msg*, *int msglen*, *FILE \*fp*);

*void*\

**p\_query**(*const u\_char \*msg*, *FILE \*fp*);

*const char \**\

**hostalias**(*const char \*name*);

*int*\

**res\_query**(*const char \*dname*, *int class*, *int type*, *u\_char \*answer*, *int anslen*);

*int*\

**res\_search**(*const char \*dname*, *int class*, *int type*, *u\_char \*answer*, *int anslen*);

*int*\

**res\_querydomain**(*const char \*name*, *const char \*domain*, *int class*, *int type*, *u\_char \*answer*, *int anslen*);

*int*\

**res\_mkquery**(*int op*, *const char \*dname*, *int class*, *int type*, *const char \*data*, *int datalen*, *struct rrec \*newrr*, *u\_char \*buf*, *int buflen*);

*int*\

**res\_send**(*const u\_char \*msg*, *int msglen*, *u\_char \*answer*, *int anslen*);

*int*\

**res\_update**(*ns\_updrec \*rrecp\_in*);

*void*\

**res\_close**(*void*);

*void*\

**herror**(*const char \*s*);

## DESCRIPTION

These routines are used for making, sending and interpreting query and reply messages with Internet domain name servers.

State information is kept in *statp* and is used to control the behavior of these functions. *statp* should be set to all zeros prior to the first call to any of these functions.

The functions **res\_init**(), **res\_isourserver**(), **fp\_nquery**(), **p\_query**(), **hostalias**(), **res\_query**(), **res\_search**(), **res\_querydomain**(), **res\_mkquery**(), **res\_send**(), **res\_update**(), **res\_close**() and **herror**() are deprecated and are supplied for compatability with old source code. They use global configuration and state information that is kept in the structure *\_res* rather than that referenced through *statp*.

Most of the values in  *statp* and *\_res* are initialized on the first call to **res\_ninit**() / **res\_init**() to reasonable defaults and can be ignored. Options stored in *statp-\>options* / *\_res.options* are defined in *resolv.h* and are as follows. Options are stored as a simple bit mask containing the bitwise  “OR” of the options enabled.

- RES\_INIT

  True if the initial name server address and default domain name are initialized (i.e., **res\_ninit**() / **res\_init**() has been called).

- RES\_DEBUG

  Print debugging messages.

- RES\_AAONLY

  Accept authoritative answers only. Should continue until it finds an authoritative answer or finds an error. Currently this is not implemented.

- RES\_USEVC

  Use TCP connections for queries instead of UDP datagrams.

- RES\_STAYOPEN

  Used with  RES\_USEVC to keep the TCP connection open between queries. This is useful only in programs that regularly do many queries. UDP should be the normal mode used.

- RES\_IGNTC

  Ignore truncation errors, i.e., don't retry with TCP.

- RES\_RECURSE

  Set the recursion-desired bit in queries. This is the default. (**res\_nsend**() / **res\_send**() does not do iterative queries and expects the name server to handle recursion.)

- RES\_DEFNAMES

  If set, **res\_nsearch**() / **res\_search**() will append the default domain name to single-component names (those that do not contain a dot). This option is enabled by default.

- RES\_DNSRCH

  If this option is set, **res\_nsearch**() / **res\_search**() will search for host names in the current domain and in parent domains; see [hostname(7)](/hostname/7.md). This is used by the standard host lookup routine [gethostbyname(3)](/gethostbyname/3.md). This option is enabled by default.

- RES\_NOALIASES

  This option turns off the user level aliasing feature controlled by the  HOSTALIASES environment variable. Network daemons should set this option.

- RES\_USE\_INET6

  This option causes  [gethostbyname(3)](/gethostbyname/3.md) to look for AAAA records before looking for A records if none are found.

- RES\_ROTATE

  This options causes the **res\_nsend**() / **res\_send**() to rotate the list of nameservers in *statp-\>nsaddr\_list* / *\_res.nsaddr\_list*.

- RES\_KEEPTSIG

  This option causes **res\_nsendsigned**() to leave the message unchanged after TSIG verification; otherwise the TSIG record would be removed and the header updated.

- RES\_NOTLDQUERY

  This option causes **res\_nsearch**() to not attempt to resolve a unqualified name as if it were a top level domain (TLD). This option can cause problems if the site has "localhost" as a TLD rather than having localhost on one or more elements of the search list. This option has no effect if neither RES\_DEFNAMES or RES\_DNSRCH is set.

The **res\_ninit**() / **res\_init**() routine reads the configuration file (if any; see [resolver(5)](/resolver/5.md)) to get the default domain name, search list and the Internet address of the local name server(s). If no server is configured, the host running the resolver is tried. The current domain name is defined by the hostname if not specified in the configuration file; it can be overridden by the environment variable  LOCALDOMAIN. This environment variable may contain several blank-separated tokens if you wish to override the “search list” on a per-process basis.  This is similar to the **search** command in the configuration file. Another environment variable  (“RES\_OPTIONS”) can be set to override certain internal resolver options which are otherwise set by changing fields in the *statp* / *\_res* structure or are inherited from the configuration file's **options** command.  The syntax of the  “RES\_OPTIONS” environment variable is explained in [resolver(5)](/resolver/5.md). Initialization normally occurs on the first call to one of the other resolver routines.

The memory referred to by *statp* must be set to all zeros prior to the first call to **res\_ninit**(). **res\_ndestroy**() should be call to free memory allocated by **res\_ninit**() after last use.

The **res\_nquery**() / **res\_query**() functions provides interfaces to the server query mechanism. They constructs a query, sends it to the local server, awaits a response, and makes preliminary checks on the reply. The query requests information of the specified *type* and *class* for the specified fully-qualified domain name *dname*. The reply message is left in the *answer* buffer with length *anslen* supplied by the caller. **res\_nquery**() / **res\_query**() return -1 on error or the length of the answer.

The **res\_nsearch**() / **res\_search**() routines make a query and awaits a response like **res\_nquery**() / **res\_query**(), but in addition, it implements the default and search rules controlled by the  RES\_DEFNAMES and  RES\_DNSRCH options. It returns the length of the first successful reply which is stored in *answer* or -1 on error.

The remaining routines are lower-level routines used by **res\_nquery**() / **res\_query**(). The **res\_nmkquery**() / **res\_mkquery**() functions constructs a standard query message and places it in *buf*. It returns the size of the query, or -1 if the query is larger than *buflen*. The query type *op* is usually  QUERY, but can be any of the query types defined in *\<arpa/nameser.h\>*. The domain name for the query is given by *dname*. *Newrr* is currently unused but is intended for making update messages.

The **res\_nsend**() / **res\_send**() / **res\_nsendsigned**() routines sends a pre-formatted query and returns an answer. It will call **res\_ninit**() / **res\_init**() if  RES\_INIT is not set, send the query to the local name server, and handle timeouts and retries.  Additionally, **res\_nsendsigned**() will use TSIG signatures to add authentication to the query and verify the response.  In this case, only one nameserver will be contacted. The length of the reply message is returned, or -1 if there were errors.

**res\_nquery**() / **res\_query**(), **res\_nsearch**() / **res\_search**() and **res\_nsend**() / **res\_send**() return a length that may be bigger than *anslen*. In that case the query should be retried with a bigger buffer. NOTE the answer to the second query may be larger still so supplying a buffer that bigger that the answer returned by the previous query is recommended.

*answer* MUST be big enough to receive a maximum UDP response from the server or  parts of the answer will be silently discarded. The default maximum UDP response size is 512 bytes.

The function **res\_ourserver\_p**() returns true when  *inp* is one of the servers in *statp-\>nsaddr\_list* / *\_res.nsaddr\_list*.

The functions **fp\_nquery**() / **p\_query**() print out the query and any answer in *msg* on *fp*. **p\_query**() is equivalent to **fp\_nquery**() with *msglen* set to 512.

The function **fp\_resstat**() prints out the active flag bits in *statp-\>options* preceeded by the text ";; res options:" on  *file*.

The functions **res\_hostalias**() / **hostalias**() lookup up name in the file referred to by the HOSTALIASES files return a fully qualified hostname if found or NULL if not found or an error occurred. **res\_hostalias**() uses *buf* to store the result in, **hostalias**() uses a static buffer.

The functions **res\_getservers**() and **res\_setservers**() are used to get and set the list of server to be queried.

The functions **res\_nupdate**() / **res\_update**() take a list of ns\_updrec *rrecp\_in*. Identifies the containing zone for each record and groups the records according to containing zone maintaining in zone order then sends and update request to the servers for these zones.  The number of zones updated is returned or -1 on error.  Note that **res\_nupdate**() will perform TSIG authenticated dynamic update operations if the key is not NULL.

The function **res\_findzonecut**() discovers the closest enclosing zone cut for a specified domain name, and finds the IP addresses of the zone's master servers.

The functions  **res\_nmkupdate**() / **res\_mkupdate**() take a linked list of ns\_updrec *rrecp\_in* and construct a UPDATE message in *buf*. **res\_nmkupdate**() / **res\_mkupdate**() return the length of the constructed message on no error or one of the following error values.

- \-1

  An error occurred parsing  *rrecp\_in*.

- \-2

  The buffer  *buf* was too small.

- \-3

  The first record was not a zone section or there was a section order problem. The section order is S\_ZONE, S\_PREREQ and S\_UPDATE.

- \-4

  A number overflow occurred.

- \-5

  Unknown operation or no records.

The functions **res\_nclose**() / **res\_close**() close any open files referenced through *statp* / *\_res*.

The function **res\_ndestroy**() calls **res\_nclose**() then frees any memory allocated by **res\_ninit**().

The **dn\_comp**() function compresses the domain name *exp\_dn* and stores it in *comp\_dn*. The size of the compressed name is returned or -1 if there were errors. The size of the array pointed to by *comp\_dn* is given by *length*. The compression uses an array of pointers *dnptrs* to previously-compressed names in the current message. The first pointer points to to the beginning of the message and the list ends with  NULL. The limit to the array is specified by *lastdnptr*. A side effect of **dn\_comp**() is to update the list of pointers for labels inserted into the message as the name is compressed.  If *dnptr* is  NULL, names are not compressed.  If *lastdnptr* is  NULL, the list of labels is not updated.

The **dn\_expand**() entry expands the compressed domain name *comp\_dn* to a full domain name. The compressed name is contained in a query or reply message; *msg* is a pointer to the beginning of the message. *eomorig* is a pointer to the first location after the message. The uncompressed name is placed in the buffer indicated by *exp\_dn* which is of size *length*. The size of compressed name is returned or -1 if there was an error.

The variables *statp-\>res\_h\_errno* / *\_res.res\_h\_errno* and external variable *h\_errno* is set whenever an error occurs during resolver operation.  The following definitions are given in *\<netdb.h\>*:

```
#define NETDB_INTERNAL -1  /* see errno */
#define NETDB_SUCCESS  0   /* no problem */
#define HOST_NOT_FOUND 1   /* Authoritative Answer Host not found */
#define TRY_AGAIN      2   /* Non-Authoritative not found, or SERVFAIL */
#define NO_RECOVERY    3   /* Non-Recoverable: FORMERR, REFUSED, NOTIMP */
#define NO_DATA        4   /* Valid name, no data for requested type */
```

The **herror**() function writes a message to the diagnostic output consisting of the string parameter *s*, the constant string ": ", and a message corresponding to the value of *h\_errno*.

The **hstrerror**() function returns a string which is the message text corresponding to the value of the *err* parameter.

## FILES

- */etc/resolv.conf*

  See  [resolver(5)](/resolver/5.md).

## SEE ALSO

[gethostbyname(3)](/gethostbyname/3.md), [hostname(7)](/hostname/7.md), [named(8)](/named/8.md), [resolver(5)](/resolver/5.md); RFC1032, RFC1033, RFC1034, RFC1035, RFC974; SMM:11,  “Name Server Operations Guide for BIND”
