---
name: "rad"
section: "8"
platform: "openbsd"
package: "man"
version: "8.0-current-20261101"
release: "OpenBSD 8.0-current (2026-11-01)"
platforms: ["openbsd"]
url: "https://new.carta.tech/rad/8"
---

# rad(8)

router advertisement daemon

## NAME

**rad** – router advertisement daemon

## SYNOPSIS

**rad** \[**-dnv**\] \[**-f** *file*\] \[**-s** *socket*\]

## DESCRIPTION

**rad** is an IPv6 router advertisement daemon. It periodically sends IPv6 router advertisement messages with prefix and default router information. Clients like [slaacd(8)](/slaacd/8.md) use these to configure IPv6 addresses on network interfaces and set default routes. Additionally it listens for IPv6 router solicitation messages and responds with router advertisements.

To have **rad** enabled at boot time, use “rcctl enable rad”, which sets

```
rad_flags=""
```

in rc.conf.local(8).

A running **rad** can be controlled with the [ractl(8)](/ractl/8.md) utility.

The options are as follows:

- **-d**

  Do not daemonize. If this option is specified, **rad** will run in the foreground and log to *stderr*.

- **-f** *file*

  Specify an alternative configuration file.

- **-n**

  Configtest mode. Only check the configuration file for validity.

- **-s** *socket*

  Use an alternate location for the default control socket.

- **-v**

  Produce more verbose output.

## FILES

- */etc/rad.conf*

  Default **rad** configuration file.

- */var/run/rad.sock*

  UNIX-domain socket used for communication with [ractl(8)](/ractl/8.md).

## SEE ALSO

[rad.conf(5)](/rad.conf/5.md), [ractl(8)](/ractl/8.md), [slaacd(8)](/slaacd/8.md)

## STANDARDS

R. Draves and D. Thaler, *Default Router Preferences and More-Specific Routes*, RFC 4191, November 2005.

R. Hinden and S. Deering, *IP Version 6 Addressing Architecture*, RFC 4291, February 2006.

T. Narten, E. Nordmark, W. Simpson, and H. Soliman, *Neighbor Discovery for IP version 6 (IPv6)*, RFC 4861, September 2007.

A. Yourtchenko and L. Colitti, *Reducing Energy Consumption of Router Advertisements*, RFC 7772, February 2016.

J. Jeong, S. Park, L. Beloeil, and S. Madanapalli, *IPv6 Router Advertisement Options for DNS Configuration*, RFC 8106, March 2017.

L. Colitti and J. Linkova, *Discovering PREF64 in Router Advertisements*, RFC 8781, April 2020.

## HISTORY

The **rad** program first appeared in OpenBSD 6.4.

## AUTHORS

The **rad** program was written by Florian Obser ⟨*florian@openbsd.org*⟩.
