---
name: "pure-statsdecode"
section: "8"
platform: "linux"
package: "pure-ftpd-common"
version: "1.0.50-2.2"
release: "Debian 13 (Trixie)"
platforms: ["linux"]
url: "https://new.carta.tech/pure-statsdecode"
---

# pure-statsdecode(8)

Show human-readable dates from a "stats" logfile

## NAME

pure-statsdecode - Show human-readable dates from a "stats" logfile

## SYNTAX

pure-statsdecode *filename*\
 pure-statsdecode *-*

## DESCRIPTION

This program decodes Pure-FTPd's "stats" log files and converts timestamps into human-readable dates.

## OPTIONS

- **-**

  means to read the standard input.

- **filename**

  is a log file produced with pure-ftpd -O ftpstats:/path/to/logfile

## EXAMPLES

To run this program the standard way type:

pure-statsdecode /var/log/pureftpd.log \> /tmp/pureftpd.humanlog

Alternativly you can run it as:

cat /var/log/pureftpd.log \| pure-statsdecode - \| gzip --best \> /tmp/pureftpd.humanlog.gz

## AUTHORS

Frank DENIS \<j at pureftpd dot org\>

## SEE ALSO

**[ftp(1)](/ftp/1.md)**, **[pure-ftpd(8)](/pure-ftpd/8.md)** **[pure-ftpwho(8)](/pure-ftpwho/8.md)** **[pure-mrtginfo(8)](/pure-mrtginfo/8.md)** **[pure-uploadscript(8)](/pure-uploadscript/8.md)** **[pure-statsdecode(8)](/pure-statsdecode/8.md)** **[pure-pw(8)](/pure-pw/8.md)** **[pure-quotacheck(8)](/pure-quotacheck/8.md)** **[pure-authd(8)](/pure-authd/8.md)** **[pure-certd(8)](/pure-certd/8.md)**

**RFC 959**, **RFC 2228**, **RFC 2389** and **RFC 2428**.
