---
name: "ptkqotd"
section: "1"
platform: "linux"
package: "ptknettools"
version: "0.2.3"
release: "Debian 3.1 (Sarge)"
platforms: ["linux"]
url: "https://new.carta.tech/ptkqotd"
---

# ptkqotd(1)

Perl/Tk Quote Of The Day (QOTD) Client for X

## NAME

ptkqotd - Perl/Tk Quote Of The Day (QOTD) Client for X

## SYNOPSIS

**ptkqotd** \[*host* \[*port*\]\]

## DESCRIPTION

*ptkqotd* is a Quote Of The Day (QOTD - TCP port 17) client for X, written  in Perl/Tk.

Quote Of The Day is a protocol supported by certain machines. When a connection is detected, it sends a short quote and closes the connection.

Because of the behaviour of the QOTD protocol, *ptkqotd* can also be used for other similar protocols, such as daytime (port 13) and systat (Active Users - port 11).

### OPTIONS

- **host**

  The host to connect to.

- **port**

  The TCP port to connect to (defaults to 17 - qotd).

## REQUIREMENTS

ptkqotd requires a fairly up-to-date version of Perl (version 5.002 or better). It also (obviously) requires Perl/Tk. Perl/Tk is available in the Nick-Ing Simmons author directory at CPAN. It is also available as a Debian package.

## AUTHOR and BUG REPORTING

ptkqotd was written by Alan Ford \<alan@whirlnet.co.uk\> Please report bugs to that address.

## SEE ALSO

[inetd(8)](/inetd/8.md), [telnet(1)](/telnet/1.md) (for bi-directional communication between hosts), and the perl-tk documentation.

The qotd protocol (port 17) is defined in RFC865. The systat (Active Users) protocol (port 11) is defined in RFC866. The daytime protocol (port 13) is defined in RFC867.

## KNOWN BUGS

There have been reports of slightly dodgy output, but I have been unable to replicate the symptoms myself.
