---
name: "named-xfer"
section: "8bind"
platform: "linux"
package: "bind"
version: "1:8.2.2p5-0slink1.1"
release: "Debian 2.1 (Slink)"
platforms: ["linux"]
url: "https://new.carta.tech/named-xfer/8bind"
---

# named-xfer(8bind)

ancillary agent for inbound zone transfers

## NAME

**@XFER\_INDOT@named-xfer** – ancillary agent for inbound zone transfers

## SYNOPSIS

**named-xfer** **-z** *zone\_to\_transfer* **-f** *db\_file* **-s** *serial\_no* \[**-d** *debuglevel*\] \[**-l** *debug\_log\_file*\] \[**-t** *trace\_file*\] \[**-p** *port#*\] \[**-S**\] *nameserver* *...*

## DESCRIPTION

**Named-xfer** is an ancillary program executed by @INDOT@named(@SYS\_OPS\_EXT@) to perform an inbound zone transfer.  It is rarely executed directly, and then only by system administrators who are trying to debug a zone transfer problem. See RFC's 1033, 1034, and 1035 for more information on the Internet name-domain system.

Options are:

- **-z** *zone\_to\_transfer*

  specifies the name of the zone to be transferred.

- **-f** *db\_file*

  specifies the name of the  *db\_file* into which the zone should be dumped when it is received from the primary server.

- **-s** *serial\_no*

  specifies the serial number of our current copy of this zone.  If the **SOA** **RR** we get from the primary server does not have a serial number higher than this, the transfer will be aborted.

- **-d** *debuglevel*

  Print debugging information. The  *debuglevel* is a number determines the level of messages printed.

- **-l** *debug\_log\_file*

  Specifies a log file for debugging messages.  The default is system-  dependent but is usually in */var/tmp* or */usr/tmp*. Note that this only applies if “**-d**” is also specified.

- **-t** *trace\_file*

  Specifies a  *trace\_file* which will contain a protocol trace of the zone transfer.  This is probably only of interest to people debugging the name server itself.

- **-p** *port#*

  Use a different port number.  The default is the standard port number as returned by  getservbyname(@LIB\_NETWORK\_EXT@) for the service  “domain”.

- **-S**

  Perform a restricted transfer of only the SOA, NS records and glue A records for the zone. The SOA record will not be loaded by  @INDOT@named(@SYS\_OPS\_EXT@) but will be used to determine when to verify the NS records.  See the  “stubs” directive in @INDOT@named(@SYS\_OPS\_EXT@) for more information.

Additional arguments are taken as name server addresses in so-called “dotted-quad” syntax  *only;* no host name are allowed here.  At least one address must be specified.   Any additional addresses will be tried, in order, if the first one fails  to transfer to us successfully.

## SEE ALSO

hostname(@DESC\_EXT@), @INDOT@named(@SYS\_OPS\_EXT@), resolver(@LIB\_NETWORK\_EXT@), resolver(@FORMAT\_EXT@), RFC 882, RFC 883, RFC 973, RFC 974, RFC 1033, RFC 1034, RFC 1035, RFC 1123, “Name Server Operations Guide for **BIND**”.
