---
name: "named-xfer"
section: "8"
platform: "linux"
package: "bind"
version: "1:8.4.7-1"
release: "Debian 4.0 (Etch)"
platforms: ["linux"]
url: "https://new.carta.tech/named-xfer"
---

# named-xfer(8)

ancillary agent for inbound zone transfers

## NAME

**named-xfer** – ancillary agent for inbound zone transfers

## SYNOPSIS

**named-xfer** **-z** *zone\_to\_transfer* **-f** *db\_file* **-s** *serial\_no* \[**-d** *debuglevel*\] \[**-l** *debug\_log\_file*\] \[**-i** *ixfr\_file*\] \[**-t** *trace\_file*\] \[**-p** *port#*\] \[**-C** *class*\] \[**-S**\] \[**-q**\] \[**-x** *ipv4\_src\_address*\] \[**-X** *ipv6\_src\_address*\] \[**-T** *tsig\_file*\] *nameserver* \[**axfr** \| **ixfr**\]

## DESCRIPTION

**Named-xfer** is an ancillary program executed by [named(8)](/named/8.md) to perform an inbound zone transfer.  It is rarely executed directly, and then only by system administrators who are trying to debug a zone transfer problem. See RFC's 1033, 1034, and 1035 for more information on the Internet name-domain system.

Options are:

- **-z** *zone\_to\_transfer*

  specifies the name of the zone to be transferred.

- **-f** *db\_file*

  specifies the name of the  *db\_file* into which the zone should be dumped when it is received from the primary server.

- **-s** *serial\_no*

  specifies the serial number of our current copy of this zone.  If the **SOA** **RR** we get from the primary server does not have a serial number higher than this, the transfer will be aborted.

- **-d** *debuglevel*

  Print debugging information. The  *debuglevel* is a number determines the level of messages printed.

- **-l** *debug\_log\_file*

  Specifies a log file for debugging messages.  The default is system-  dependent but is usually in */var/tmp* or */usr/tmp*. Note that this only applies if “**-d**” is also specified.

- **-i** *ixfr\_file*

  Specifies the name of the  *ixfr\_file* into which the zone changes from Incremental Zone Transfer (IXFR) should be dumped when it is received from the primary server.

- **-t** *trace\_file*

  Specifies a  *trace\_file* which will contain a protocol trace of the zone transfer.  This is probably only of interest to people debugging the name server itself.

- **-p** *port#*

  Use a different port number.  The default is the standard port number as returned by  [getservbyname(3)](/getservbyname/3.md) for the service  “domain”.

- **-C** *class*

  Defines which class to use. Defaults to 'IN'.

- **-S**

  Perform a restricted transfer of only the SOA, NS records and glue A records for the zone. The SOA record will not be loaded by  [named(8)](/named/8.md) but will be used to determine when to verify the NS records.  See the  “stubs” directive in [named(8)](/named/8.md) for more information.

- **-q**

  Tells named-xfer to be quiet.

- **-x** *ipv4\_src\_address*

  Specifies the IPv4 source address to use for this query.

- **-X** *ipv6\_src\_address*

  Specifies the IPv6 source address to use for this query.

- **-T** *tsig\_file*

  Specifies a file to transfer TSIG information to named-xfer. Multiple entries of the following format:

  - IP address

    When connecting to this address use this TSIG key.

  - key name

    - algorithm

    157 (HMAC-MD5) is the only algorithm supported.

  - key data

    base64

    named-xfer expects this file to be temporary in nature and will explicitly delete this file after its use.

Additional arguments are taken as name server addresses in so-called “dotted-quad” syntax  *only*; no host name are allowed here.  At least one address must be specified.   Any additional addresses will be tried, in order, if the first one fails  to transfer to us successfully. The  **axfr** or  **ixfr** after name server address designates the type of zone transfer to perform. Use  **axfr** for a full zone transfer or **ixfr** for an incremental zone transfer.

## SEE ALSO

[hostname(7)](/hostname/7.md), [named(8)](/named/8.md), [resolver(3)](/resolver/3.md), [resolver(5)](/resolver/5.md), RFC 882, RFC 883, RFC 973, RFC 974, RFC 1033, RFC 1034, RFC 1035,  RFC 1123, RFC 1995 “Name Server Operations Guide for **BIND**”.
