dns3tnm
Query the domain name system of the internet.
Overview
The Tnm::dns command allows to query the Internet Domain Name System (DNS) (RFC 1034, RFC 1035, RFC 974, RFC 1912) for host information. The main purpose of this command is to convert host names into IP addresses and vice versa. The Tnm::dns command also allows to retrieve host information records as well as mail exchanger records.
DNS command
Tnm::dns[options]-
Invoking the
Tnm::dnscommand with options but without any command arguments allows to retrieve and change the default values. See the description of supported options below. Default values are bound to a Tcl interpreter which allows to have multiple Tcl interpreter with different defaults.
Tnm::dns[options]addresshost-
The Tnm::dns address command sends a query to retrieve the address record for the specified host. The command returns the list of IP addresses for the given host name.
Tnm::dns[options]nameaddress-
The Tnm::dns name command sends a query to retrieve the domain name pointer record. A pointer record maps an IP address to a fully qualified domain name. The command returns the fully qualified domain name for the given IP address.
Tnm::dns[options]hinfoname-
The Tnm::dns hinfo command sends a query to retrieve the host information (HINFO) record. The command returns a list containing two elements. The first element describes the hardware type and the second element the operating system.
Tnm::dns[options]mxname-
The Tnm::dns mx command sends a query to retrieve the mail exchanger (MX) record. The command returns a list of mail exchanger records if name is a domain name for which one or more MX records exist. Each element of this list contains a fully qualified domain name and its priority.
Tnm::dns[options]soaname-
The Tnm::dns soa command sends a query to retrieve the start of authority record for a DNS domain. The command returns the name of the authoritative DNS server of the DNS domain name.
Options
-
-server server -
The
-serveroption defines the list of DNS server which will be used to process the request. The default value is the list of default DNS server configured on the local system.
-
-timeout time -
The
-timeoutoption defines the time the dns command will wait for a response. The time is defined in seconds with a default of 2 seconds.
-
-retries number -
The
-retriesoption defines how many times a request is retransmitted during the timeout interval. The default number of retries is 2. Please note, that many resolver double the last timeout after every retry.
Releases
4 releases since Debian 2.0 (Hamm); the text changed 1 time.