Regexp::Common::URI(3pm)

Regexp::Common::URI3pm

Usage

    use Regexp::Common qw /URI/;
    while (<>) {
        /$RE{URI}{HTTP}/       and  print "Contains an HTTP URI.\n";
    }

Overview

Patterns for the following URIs are supported: fax, file, FTP, gopher, HTTP, news, NTTP, pop, prospero, tel, telnet, tv and WAIS. Each is documented in the Regexp::Common::URI::scheme, manual page, for the appropriate scheme (in lowercase), except for NNTP URIs which are found in Regexp::Common::URI::news.

$re{uri}

Return a pattern that recognizes any of the supported URIs. With "{-keep}", only the entire URI is returned (in $1).

References

[DRAFT-URI-TV]

Zigmond, D. and Vickers, M: Uniform Resource Identifiers for Television Broadcasts. December 2000.

[DRAFT-URL-FTP]

Casey, James: A FTP URL Format. November 1996.

[RFC 1035]

Mockapetris, P.: DOMAIN NAMES - IMPLEMENTATION AND SPECIFICATION. November 1987.

[RFC 1738]

Berners-Lee, Tim, Masinter, L., McCahill, M.: Uniform Resource Locators (URL). December 1994.

[RFC 2396]

Berners-Lee, Tim, Fielding, R., and Masinter, L.: Uniform Resource Identifiers (URI): Generic Syntax. August 1998.

[RFC 2616]

Fielding, R., Gettys, J., Mogul, J., Frystyk, H., Masinter, L., Leach, P. and Berners-Lee, Tim: Hypertext Transfer Protocol -- HTTP/1.1. June 1999.

[RFC 2806]

Vaha-Sipila, A.: URLs for Telephone Calls. April 2000.

Maintenance

This package is maintained by Abigail ([email protected]).

Bugs and irritations

Bound to be plenty.

For a start, there are many common regexes missing. Send them in to [email protected].

Releases

12 releases since Debian 3.1 (Sarge); the text changed 10 times.

  1. 3.1
  2. 4.0
  3. 5.0
  4. 6.0
  5. 7
  6. 8
  7. 9
  8. 10–11
  9. 12
  10. 13
  11. Arch

Author

Damian Conway ([email protected])

From perl-regexp-common 2024080801-4 in Arch Linux 2026-11-01. Parsed by carta from the page's man source.