Net::DNS::SEC3pm
Dnssec extensions to net::dns
Usage
use Net::DNS::SEC;
Overview
Net::DNS::SEC is installed as an extension to an existing Net::DNS installation providing packages to support DNSSEC as specified in RFC4033, RFC4034, RFC4035 and related documents.
It also provides support for SIG0 which is useful for dynamic updates.
Implements cryptographic signature generation and verification functions using RSA, DSA, ECDSA, and Edwards curve algorithms.
The extended features are made available by replacing Net::DNS by Net::DNS::SEC in the use declaration.
Utility functions
algorithm
$mnemonic = algorithm( 5 );$numeric = algorithm( 'RSA-SHA1' );print "algorithm mnemonic\t", $mnemonic, "\n";print "algorithm number:\t", $numeric, "\n";
algorithm() provides conversions between an algorithm code number and the corresponding mnemonic.
digtype
$mnemonic = digtype( 2 );$numeric = digtype( 'SHA-256' );print "digest type mnemonic\t", $mnemonic, "\n";print "digest type number:\t", $numeric, "\n";
digtype() provides conversions between a digest type number and the corresponding mnemonic.
key_difference
@result = key_difference( \@a, \@b );
Fills @result with all keys in array @a that are not in array @b.
Releases
9 releases since Debian 6.0 (Squeeze); the text changed 8 times.