---
name: "libressl-X509_check_host"
section: "3"
platform: "linux"
package: "libressl"
version: "4.4.0-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/libressl-X509_check_host"
---

# libressl-X509\_check\_host(3)

X.509 certificate matching

## NAME

**X509\_check\_host**, **X509\_check\_email**, **X509\_check\_ip**, **X509\_check\_ip\_asc** – X.509 certificate matching

## SYNOPSIS

Crypto Library (libcrypto, -lcrypto)

**#include \<openssl/x509v3.h\>**

*int*\

**X509\_check\_host**(*X509 \*x*, *const char \*name*, *size\_t namelen*, *unsigned int flags*, *char \*\*peername*);

*int*\

**X509\_check\_email**(*X509 \*x*, *const char \*address*, *size\_t addresslen*, *unsigned int flags*);

*int*\

**X509\_check\_ip**(*X509 \*x*, *const unsigned char \*address*, *size\_t addresslen*, *unsigned int flags*);

*int*\

**X509\_check\_ip\_asc**(*X509 \*x*, *const char \*address*, *unsigned int flags*);

## DESCRIPTION

The certificate matching functions are used to check whether a certificate matches a given hostname, email address, or IP address. The validity of the certificate and its trust level has to be checked by other means.

**X509\_check\_host**() checks if the certificate Subject Alternative Name (SAN) or Subject CommonName (CN) matches the specified hostname, which must be encoded in the preferred name syntax described in section 3.5 of RFC 1034. By default, wildcards are supported and they match only in the left-most label; they may match part of that label with an explicit prefix or suffix. For example, by default, the host *name* "www.example.com" would match a certificate with a SAN or CN value of "\*.example.com", "w\*.example.com" or "\*w.example.com".

Per section 6.4.2 of RFC 6125, *name* values representing international domain names must be given in A-label form. The *namelen* argument must be the number of characters in the name string or zero, in which case the length is calculated with **strlen**(*name*). When *name* starts with a dot (e.g. ".example.com"), it will be matched by a certificate valid for any sub-domain of *name*; see also *X509\_CHECK\_FLAG\_SINGLE\_LABEL\_SUBDOMAINS* below.

When the certificate is matched and *peername* is not NULL, a pointer to a copy of the matching SAN or CN from the peer certificate is stored at the address passed in *peername*. The application is responsible for freeing the peername via [free(3)](/free/3.md) when it is no longer needed.

**X509\_check\_email**() checks if the certificate matches the specified email *address*. Only the mailbox syntax of RFC 822 is supported. Comments are not allowed, and no attempt is made to normalize quoted characters. The *addresslen* argument must be the number of characters in the address string or zero, in which case the length is calculated with **strlen**(*address*).

**X509\_check\_ip**() checks if the certificate matches a specified IPv4 or IPv6 address. The *address* array is in binary format, in network byte order. The length is either 4 (IPv4) or 16 (IPv6). Only explicitly marked addresses in the certificates are considered; IP addresses stored in DNS names and Common Names are ignored.

**X509\_check\_ip\_asc**() is similar, except that the NUL-terminated string *address* is first converted to the internal representation.

The *flags* argument is usually 0, but it can be the bitwise OR of the following flags.

The X509\_CHECK\_FLAG\_ALWAYS\_CHECK\_SUBJECT flag causes the function to consider the subject DN even if the certificate contains at least one subject alternative name of the right type (DNS name or email address as appropriate); the default is to ignore the subject DN when at least one corresponding subject alternative names is present.

The remaining flags are only meaningful for **X509\_check\_host**().

The X509\_CHECK\_FLAG\_NO\_WILDCARDS flag disables wildcard expansion.

The X509\_CHECK\_FLAG\_NO\_PARTIAL\_WILDCARDS flag suppresses support for "\*" as a wildcard pattern in labels that have a prefix or suffix, such as "www\*" or "\*www".

The X509\_CHECK\_FLAG\_MULTI\_LABEL\_WILDCARDS flag allows a "\*" that constitutes the complete label of a DNS name (e.g. "\*.example.com") to match more than one label in *name*.

The X509\_CHECK\_FLAG\_SINGLE\_LABEL\_SUBDOMAINS flag restricts *name* values which start with ".", that would otherwise match any sub-domain in the peer certificate, to only match direct child sub-domains. Thus, for instance, with this flag set a *name* of ".example.com" would match a peer certificate with a DNS name of "www.example.com", but would not match a peer certificate with a DNS name of "www.sub.example.com".

## RETURN VALUES

The functions return 1 for a successful match, 0 for a failed match and -1 for an internal error: typically a memory allocation failure or an ASN.1 decoding error.

All functions can also return -2 if the input is malformed. For example, **X509\_check\_host**() returns -2 if the provided *name* contains embedded NUL bytes.

## SEE ALSO

SSL\_set1\_host(3), X509\_EXTENSION\_new(3), X509\_get1\_email(3), X509\_new(3), X509\_VERIFY\_PARAM\_set1\_host(3)

## HISTORY

These functions first appeared in OpenSSL 1.0.2 and have been available since OpenBSD 6.1.
