---
name: "ldns_zone_sort"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_zone_sort"
---

# ldns\_zone\_sort(3)

sort a zone and get the glue records

## NAME

ldns\_zone\_sort, ldns\_zone\_glue\_rr\_list - sort a zone and get the glue records

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

void ldns\_zone\_sort(ldns\_zone \*zone);

ldns\_rr\_list\* ldns\_zone\_glue\_rr\_list(const ldns\_zone \*z);

## DESCRIPTION

*ldns\_zone\_sort*() Sort the rrs in a zone, with the current impl. this is slow .br **zone**: the zone to sort

*ldns\_zone\_glue\_rr\_list*() Retrieve all resource records from the zone that are glue records. The resulting list does are pointer references to the zone's data.

Due to the current zone implementation (as a list of rr's), this function is extremely slow. Another (probably better) way to do this is to use an ldns\_dnssec\_zone structure and the  ldns\_dnssec\_mark\_and\_get\_glue() function.

.br **z**: the zone to look for glue .br Returns the rr\_list with the glue

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_zone*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
