---
name: "ldns_zone_sign"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_zone_sign"
---

# ldns\_zone\_sign(3)

dnssec sign a zone

## NAME

ldns\_zone\_sign, ldns\_zone\_sign\_nsec3 - dnssec sign a zone

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_zone\* ldns\_zone\_sign(const ldns\_zone \*zone, ldns\_key\_list \*key\_list);

ldns\_zone\* ldns\_zone\_sign\_nsec3(ldns\_zone \*zone, ldns\_key\_list \*key\_list, uint8\_t algorithm, uint8\_t flags, uint16\_t iterations, uint8\_t salt\_length, uint8\_t \*salt);

## DESCRIPTION

*ldns\_zone\_sign*() Signs the zone, and returns a newly allocated signed zone .br **zone**: the zone to sign .br **key\_list**: list of keys to sign with .br Returns signed zone

*ldns\_zone\_sign\_nsec3*() Signs the zone with NSEC3, and returns a newly allocated signed zone .br **zone**: the zone to sign .br **key\_list**: list of keys to sign with .br **algorithm**: the NSEC3 hashing algorithm to use .br **flags**: NSEC3 flags .br **iterations**: the number of NSEC3 hash iterations to use .br **salt\_length**: the length (in octets) of the NSEC3 salt .br **salt**: the NSEC3 salt data .br Returns signed zone

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
