---
name: "ldns_zone_set_rrs"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_zone_set_rrs"
---

# ldns\_zone\_set\_rrs(3)

ldns\_zone set content

## NAME

ldns\_zone\_set\_rrs, ldns\_zone\_set\_soa - ldns\_zone set content

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

void ldns\_zone\_set\_rrs(ldns\_zone \*z, ldns\_rr\_list \*rrlist);

void ldns\_zone\_set\_soa(ldns\_zone \*z, ldns\_rr \*soa);

## DESCRIPTION

*ldns\_zone\_set\_rrs*() Set the zone's contents .br **z**: the zone to put the new soa in .br **rrlist**: the rrlist to use

*ldns\_zone\_set\_soa*() Set the zone's soa record .br **z**: the zone to put the new soa in .br **soa**: the soa to set

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_zone*, *ldns\_zone\_rrs*, *ldns\_zone\_soa*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
