---
name: "ldns_zone_rrs"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_zone_rrs"
---

# ldns\_zone\_rrs(3)

ldns\_zone get content

## NAME

ldns\_zone\_rrs, ldns\_zone\_soa - ldns\_zone get content

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_rr\_list \* ldns\_zone\_rrs(const ldns\_zone \*z);

ldns\_rr \* ldns\_zone\_soa(const ldns\_zone \*z);

## DESCRIPTION

*ldns\_zone\_rrs*() Get a list of a zone's content. Note that the SOA isn't included in this list. You need to get the  with ldns\_zone\_soa. .br **z**: the zone to read from .br Returns the rrs from this zone

*ldns\_zone\_soa*() Return the soa record of a zone .br **z**: the zone to read from .br Returns the soa record in the zone

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_zone ldns\_zone\_set\_rrs*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
