---
name: "ldns_zone_rr_count"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_zone_rr_count"
---

# ldns\_zone\_rr\_count(3)

get ldns\_zone size

## NAME

ldns\_zone\_rr\_count - get ldns\_zone size

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

size\_t ldns\_zone\_rr\_count(const ldns\_zone \*z);

## DESCRIPTION

*ldns\_zone\_rr\_count*() Returns the number of resource records in the zone, NOT counting the SOA record .br **z**: the zone to read from .br Returns the number of rr's in the zone

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_zone*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
