---
name: "ldns_verify_rrsig_dsa"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_verify_rrsig_dsa"
---

# ldns\_verify\_rrsig\_dsa(3)

verify signature data buffers

## NAME

ldns\_verify\_rrsig\_dsa, ldns\_verify\_rrsig\_rsasha1, ldns\_verify\_rrsig\_rsamd5 - verify signature data buffers

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_status ldns\_verify\_rrsig\_dsa(ldns\_buffer \*sig, ldns\_buffer \*rrset, ldns\_buffer \*key);

ldns\_status ldns\_verify\_rrsig\_rsasha1(ldns\_buffer \*sig, ldns\_buffer \*rrset, ldns\_buffer \*key);

ldns\_status ldns\_verify\_rrsig\_rsamd5(ldns\_buffer \*sig, ldns\_buffer \*rrset, ldns\_buffer \*key);

## DESCRIPTION

*ldns\_verify\_rrsig\_dsa*() verifies a buffer with signature data (DSA) for a buffer with rrset data  with a buffer with key data.

.br **sig**: the signature data .br **rrset**: the rrset data, sorted and processed for verification .br **key**: the key data

*ldns\_verify\_rrsig\_rsasha1*() verifies a buffer with signature data (RSASHA1) for a buffer with rrset data  with a buffer with key data.

.br **sig**: the signature data .br **rrset**: the rrset data, sorted and processed for verification .br **key**: the key data

*ldns\_verify\_rrsig\_rsamd5*() verifies a buffer with signature data (RSAMD5) for a buffer with rrset data  with a buffer with key data.

.br **sig**: the signature data .br **rrset**: the rrset data, sorted and processed for verification .br **key**: the key data

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_key*, *ldns\_sign\_public*, *ldns\_zone\_sign*, *ldns\_verify*, *ldns\_verify\_rrsig*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
