---
name: "ldns_verify_notime"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_verify_notime"
---

# ldns\_verify\_notime(3)

verify rrsigs

## NAME

ldns\_verify, ldns\_verify\_rrsig, ldns\_verify\_rrsig\_keylist, ldns\_verify\_rrsig\_keylist\_notime, ldns\_verify\_notime - verify rrsigs

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_status ldns\_verify(ldns\_rr\_list \*rrset, ldns\_rr\_list \*rrsig, const ldns\_rr\_list \*keys, ldns\_rr\_list \*good\_keys);

ldns\_status ldns\_verify\_rrsig(ldns\_rr\_list \*rrset, ldns\_rr \*rrsig, ldns\_rr \*key);

ldns\_status ldns\_verify\_rrsig\_keylist(ldns\_rr\_list \*rrset, ldns\_rr \*rrsig, const ldns\_rr\_list \*keys, ldns\_rr\_list \*good\_keys);

ldns\_status ldns\_verify\_rrsig\_keylist\_notime(const ldns\_rr\_list \*rrset, const ldns\_rr \*rrsig, const ldns\_rr\_list \*keys, ldns\_rr\_list \*good\_keys);

ldns\_status ldns\_verify\_notime(ldns\_rr\_list \*rrset, ldns\_rr\_list \*rrsig, const ldns\_rr\_list \*keys, ldns\_rr\_list \*good\_keys);

## DESCRIPTION

*ldns\_verify*() Verifies a list of signatures for one rrset.

.br **rrset**: the rrset to verify .br **rrsig**: a list of signatures to check .br **keys**: a list of keys to check with .br **good\_keys**: if this is a (initialized) list, the pointer to keys from keys that validate one of the signatures are added to it .br Returns status LDNS\_STATUS\_OK if there is at least one correct key

*ldns\_verify\_rrsig*() verify an rrsig with 1 key .br **rrset**: the rrset .br **rrsig**: the rrsig to verify .br **key**: the key to use .br Returns status message whether verification succeeded.

*ldns\_verify\_rrsig\_keylist*() Verifies an rrsig. All keys in the keyset are tried. .br **rrset**: the rrset to check .br **rrsig**: the signature of the rrset .br **keys**: the keys to try .br **good\_keys**: if this is a (initialized) list, the pointer to keys from keys that validate one of the signatures are added to it .br Returns a list of keys which validate the rrsig + rrset. Returns status LDNS\_STATUS\_OK if at least one key matched. Else an error.

*ldns\_verify\_rrsig\_keylist\_notime*() Verifies an rrsig. All keys in the keyset are tried. Time is not checked. .br **rrset**: the rrset to check .br **rrsig**: the signature of the rrset .br **keys**: the keys to try .br **good\_keys**: if this is a (initialized) list, the pointer to keys from keys that validate one of the signatures are added to it .br Returns a list of keys which validate the rrsig + rrset. Returns status LDNS\_STATUS\_OK if at least one key matched. Else an error.

*ldns\_verify\_notime*() Verifies a list of signatures for one rrset, but disregard the time. Inception and Expiration are not checked.

.br **rrset**: the rrset to verify .br **rrsig**: a list of signatures to check .br **keys**: a list of keys to check with .br **good\_keys**: if this is a (initialized) list, the pointer to keys from keys that validate one of the signatures are added to it .br Returns status LDNS\_STATUS\_OK if there is at least one correct key

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_verify\_rrsig\_evp*, *ldns\_verify\_rrsig\_dsa*, *ldns\_verify\_rrsig\_rsasha1*, *ldns\_verify\_rrsig\_rsamd5*, *ldns\_sign\_public*, *ldns\_zone\_sign*, *ldns\_key*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
