---
name: "ldns_update_set_adcount"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_update_set_adcount"
---

# ldns\_update\_set\_adcount(3)

set the update packet counters

## NAME

ldns\_update\_set\_zocount, ldns\_update\_set\_prcount, ldns\_update\_set\_upcount, ldns\_update\_set\_adcount - set the update packet counters

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

 ldns\_update\_set\_zocount();

void ldns\_update\_set\_prcount(ldns\_pkt \*p, uint16\_t c);

void ldns\_update\_set\_upcount(ldns\_pkt \*p, uint16\_t c);

void ldns\_update\_set\_adcount(ldns\_pkt \*p, uint16\_t c);

## DESCRIPTION

*ldns\_update\_set\_zocount*()

*ldns\_update\_set\_prcount*() Set the pr count .br **p**: the packet .br **c**: the pr count to set

*ldns\_update\_set\_upcount*() Set the up count .br **p**: the packet .br **c**: the up count to set

*ldns\_update\_set\_adcount*() Set the ad count .br **p**: the packet .br **c**: the ad count to set

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_update\_pkt\_new*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
