---
name: "ldns_update_pkt_new"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_update_pkt_new"
---

# ldns\_update\_pkt\_new(3)

create an update packet

## NAME

ldns\_update\_pkt\_new - create an update packet

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_pkt\* ldns\_update\_pkt\_new(ldns\_rdf \*zone\_rdf, ldns\_rr\_class clas, const ldns\_rr\_list \*pr\_rrlist, const ldns\_rr\_list \*up\_rrlist, const ldns\_rr\_list \*ad\_rrlist);

## DESCRIPTION

*ldns\_update\_pkt\_new*() create an update packet from zone name, class and the rr lists .br **zone\_rdf**: name of the zone The returned packet will take ownership of zone\_rdf, so the caller should not free it .br **clas**: zone class .br **pr\_rrlist**: list of Prerequisite Section RRs .br **up\_rrlist**: list of Updates Section RRs .br **ad\_rrlist**: list of Additional Data Section RRs (currently unused) .br Returns the new packet

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_update\_pkt\_tsig\_add*, *ldns\_update\_pkt\_tsig\_add*, *ldns\_update\_zocount*, *ldns\_update\_prcount*, *ldns\_update\_upcount*, *ldns\_update\_adcount*, *ldns\_update\_set\_zocount*, *ldns\_update\_set\_prcount*, *ldns\_update\_set\_upcount*, *ldns\_update\_set\_adcount*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
