---
name: "ldns_update_adcount"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_update_adcount"
---

# ldns\_update\_adcount(3)

return update packet counters

## NAME

ldns\_update\_zocount, ldns\_update\_prcount, ldns\_update\_upcount, ldns\_update\_adcount - return update packet counters

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

uint16\_t ldns\_update\_zocount(const ldns\_pkt \*p);

uint16\_t ldns\_update\_prcount(const ldns\_pkt \*p);

uint16\_t ldns\_update\_upcount(const ldns\_pkt \*p);

 ldns\_update\_adcount();

## DESCRIPTION

*ldns\_update\_zocount*() Get the zo count .br **p**: the packet .br Returns the zo count

*ldns\_update\_prcount*() Get the zo count .br **p**: the packet .br Returns the pr count

*ldns\_update\_upcount*() Get the zo count .br **p**: the packet .br Returns the up count

*ldns\_update\_adcount*()

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_update\_pkt\_new*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
