---
name: "ldns_str2period"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_str2period"
---

# ldns\_str2period(3)

converts a ttl value (like 5d2h) to a long

## NAME

ldns\_str2period - converts a ttl value (like 5d2h) to a long

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

uint32\_t ldns\_str2period(const char \*nptr, const char \*\*endptr);

## DESCRIPTION

*ldns\_str2period*() converts a ttl value (like 5d2h) to a long. .br **nptr**: the start of the string .br **endptr**: points to the last char in case of error .br Returns the convert duration value

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
