---
name: "ldns_sign_public_dsa"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_sign_public_dsa"
---

# ldns\_sign\_public\_dsa(3)

sign buffer

## NAME

ldns\_sign\_public\_dsa, ldns\_sign\_public\_rsamd5, ldns\_sign\_public\_rsasha1 - sign buffer

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_rdf\* ldns\_sign\_public\_dsa(ldns\_buffer \*to\_sign, DSA \*key);

ldns\_rdf\* ldns\_sign\_public\_rsamd5(ldns\_buffer \*to\_sign, RSA \*key);

ldns\_rdf\* ldns\_sign\_public\_rsasha1(ldns\_buffer \*to\_sign, RSA \*key);

## DESCRIPTION

*ldns\_sign\_public\_dsa*() Sign a buffer with the DSA key (hash with SHA1)

.br **to\_sign**: The ldns\_buffer containing raw data that is to be signed .br **key**: The DSA key structure to sign with .br Returns a ldns\_rdf for the RRSIG ldns\_rr

*ldns\_sign\_public\_rsamd5*() Sign a buffer with the RSA key (hash with MD5) .br **to\_sign**: buffer with the data .br **key**: the key to use .br Returns a ldns\_rdf with the signed data

*ldns\_sign\_public\_rsasha1*() Sign a buffer with the RSA key (hash with SHA1) .br **to\_sign**: buffer with the data .br **key**: the key to use .br Returns a ldns\_rdf with the signed data

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_sign\_public*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
