---
name: "ldns_sign_public"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_sign_public"
---

# ldns\_sign\_public(3)

sign an rrset

## NAME

ldns\_sign\_public - sign an rrset

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_rr\_list\* ldns\_sign\_public(ldns\_rr\_list \*rrset, ldns\_key\_list \*keys);

## DESCRIPTION

*ldns\_sign\_public*() Sign an rrset .br **rrset**: the rrset .br **keys**: the keys to use .br Returns a rr\_list with the signatures

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_sign\_public\_dsa*, *ldns\_sign\_public\_rsamd5*, *ldns\_sign\_public\_rsasha1*, *ldns\_verify*, *ldns\_verify\_rrsig*, *ldns\_key*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
