---
name: "ldns_send"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_send"
---

# ldns\_send(3)

send a packet

## NAME

ldns\_send - send a packet

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_status ldns\_send(ldns\_pkt \*\*pkt, ldns\_resolver \*r, const ldns\_pkt \*query\_pkt);

## DESCRIPTION

*ldns\_send*() Sends ptk to the nameserver at the resolver object. Returns the data as a ldns\_pkt

.br **pkt**: packet received from the nameserver .br **r**: the resolver to use  .br **query\_pkt**: the query to send .br Returns status

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_pkt*, *ldns\_resolver*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
