---
name: "ldns_rr_uncompressed_size"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_rr_uncompressed_size"
---

# ldns\_rr\_uncompressed\_size(3)

calculates the uncompressed size of an RR

## NAME

ldns\_rr\_uncompressed\_size - calculates the uncompressed size of an RR

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

size\_t ldns\_rr\_uncompressed\_size(const ldns\_rr \*r);

## DESCRIPTION

*ldns\_rr\_uncompressed\_size*() calculates the uncompressed size of an RR. .br **r**: the rr to operate on .br Returns size of the rr

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
