---
name: "ldns_rr_set_type"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_rr_set_type"
---

# ldns\_rr\_set\_type(3)

set ldns\_rr attributes

## NAME

ldns\_rr\_set\_owner, ldns\_rr\_set\_ttl, ldns\_rr\_set\_type, ldns\_rr\_set\_rd\_count, ldns\_rr\_set\_class, ldns\_rr\_set\_rdf - set ldns\_rr attributes

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

void ldns\_rr\_set\_owner(ldns\_rr \*rr, ldns\_rdf \*owner);

void ldns\_rr\_set\_ttl(ldns\_rr \*rr, uint32\_t ttl);

void ldns\_rr\_set\_type(ldns\_rr \*rr, ldns\_rr\_type rr\_type);

void ldns\_rr\_set\_rd\_count(ldns\_rr \*rr, size\_t count);

void ldns\_rr\_set\_class(ldns\_rr \*rr, ldns\_rr\_class rr\_class);

ldns\_rdf\* ldns\_rr\_set\_rdf(ldns\_rr \*rr, const ldns\_rdf \*f, size\_t position);

## DESCRIPTION

*ldns\_rr\_set\_owner*() sets the owner in the rr structure. .br **\*rr**: rr to operate on .br **\*owner**: set to this owner .br Returns void

*ldns\_rr\_set\_ttl*() sets the ttl in the rr structure. .br **\*rr**: rr to operate on .br **ttl**: set to this ttl .br Returns void

*ldns\_rr\_set\_type*() sets the type in the rr. .br **\*rr**: rr to operate on .br **rr\_type**: set to this type .br Returns void

*ldns\_rr\_set\_rd\_count*() sets the rd\_count in the rr. .br **\*rr**: rr to operate on .br **count**: set to this count .br Returns void

*ldns\_rr\_set\_class*() sets the class in the rr. .br **\*rr**: rr to operate on .br **rr\_class**: set to this class .br Returns void

*ldns\_rr\_set\_rdf*() sets a rdf member, it will be set on the position given. The old value is returned, like pop. .br **\*rr**: the rr to operate on .br **\*f**: the rdf to set .br **position**: the position the set the rdf .br Returns the old value in the rr, NULL on failure

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
