---
name: "ldns_rr_rrsig_algorithm"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_rr_rrsig_algorithm"
---

# ldns\_rr\_rrsig\_algorithm(3)

get and set RRSIG RR rdata fields

## NAME

ldns\_rr\_rrsig\_typecovered, ldns\_rr\_rrsig\_set\_typecovered, ldns\_rr\_rrsig\_algorithm, ldns\_rr\_rrsig\_set\_algorithm, ldns\_rr\_rrsig\_labels, ldns\_rr\_rrsig\_set\_labels, ldns\_rr\_rrsig\_origttl, ldns\_rr\_rrsig\_set\_origttl, ldns\_rr\_rrsig\_expiration, ldns\_rr\_rrsig\_set\_expiration, ldns\_rr\_rrsig\_inception, ldns\_rr\_rrsig\_set\_inception, ldns\_rr\_rrsig\_keytag, ldns\_rr\_rrsig\_set\_keytag, ldns\_rr\_rrsig\_signame, ldns\_rr\_rrsig\_set\_signame, ldns\_rr\_rrsig\_sig, ldns\_rr\_rrsig\_set\_sig - get and set RRSIG RR rdata fields

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_rdf\* ldns\_rr\_rrsig\_typecovered(const ldns\_rr \*r);

bool ldns\_rr\_rrsig\_set\_typecovered(ldns\_rr \*r, ldns\_rdf \*f);

ldns\_rdf\* ldns\_rr\_rrsig\_algorithm(const ldns\_rr \*r);

bool ldns\_rr\_rrsig\_set\_algorithm(ldns\_rr \*r, ldns\_rdf \*f);

ldns\_rdf\* ldns\_rr\_rrsig\_labels(const ldns\_rr \*r);

bool ldns\_rr\_rrsig\_set\_labels(ldns\_rr \*r, ldns\_rdf \*f);

ldns\_rdf\* ldns\_rr\_rrsig\_origttl(const ldns\_rr \*r);

bool ldns\_rr\_rrsig\_set\_origttl(ldns\_rr \*r, ldns\_rdf \*f);

ldns\_rdf\* ldns\_rr\_rrsig\_expiration(const ldns\_rr \*r);

bool ldns\_rr\_rrsig\_set\_expiration(ldns\_rr \*r, ldns\_rdf \*f);

ldns\_rdf\* ldns\_rr\_rrsig\_inception(const ldns\_rr \*r);

bool ldns\_rr\_rrsig\_set\_inception(ldns\_rr \*r, ldns\_rdf \*f);

ldns\_rdf\* ldns\_rr\_rrsig\_keytag(const ldns\_rr \*r);

bool ldns\_rr\_rrsig\_set\_keytag(ldns\_rr \*r, ldns\_rdf \*f);

ldns\_rdf\* ldns\_rr\_rrsig\_signame(const ldns\_rr \*r);

bool ldns\_rr\_rrsig\_set\_signame(ldns\_rr \*r, ldns\_rdf \*f);

ldns\_rdf\* ldns\_rr\_rrsig\_sig(const ldns\_rr \*r);

bool ldns\_rr\_rrsig\_set\_sig(ldns\_rr \*r, ldns\_rdf \*f);

## DESCRIPTION

*ldns\_rr\_rrsig\_typecovered*() returns the type covered of a LDNS\_RR\_TYPE\_RRSIG rr .br **r**: the resource record .br Returns a ldns\_rdf\* with the type covered or NULL on failure

*ldns\_rr\_rrsig\_set\_typecovered*() sets the typecovered of a LDNS\_RR\_TYPE\_RRSIG rr .br **r**: the rr to use .br **f**: the typecovered to set .br Returns true on success, false otherwise

*ldns\_rr\_rrsig\_algorithm*() returns the algorithm of a LDNS\_RR\_TYPE\_RRSIG RR .br **r**: the resource record .br Returns a ldns\_rdf\* with the algorithm or NULL on failure

*ldns\_rr\_rrsig\_set\_algorithm*() sets the algorithm of a LDNS\_RR\_TYPE\_RRSIG rr .br **r**: the rr to use .br **f**: the algorithm to set .br Returns true on success, false otherwise

*ldns\_rr\_rrsig\_labels*() returns the number of labels of a LDNS\_RR\_TYPE\_RRSIG RR .br **r**: the resource record .br Returns a ldns\_rdf\* with the number of labels or NULL on failure

*ldns\_rr\_rrsig\_set\_labels*() sets the number of labels of a LDNS\_RR\_TYPE\_RRSIG rr .br **r**: the rr to use .br **f**: the number of labels to set .br Returns true on success, false otherwise

*ldns\_rr\_rrsig\_origttl*() returns the original TTL of a LDNS\_RR\_TYPE\_RRSIG RR .br **r**: the resource record .br Returns a ldns\_rdf\* with the original TTL or NULL on failure

*ldns\_rr\_rrsig\_set\_origttl*() sets the original TTL of a LDNS\_RR\_TYPE\_RRSIG rr .br **r**: the rr to use .br **f**: the original TTL to set .br Returns true on success, false otherwise

*ldns\_rr\_rrsig\_expiration*() returns the expiration time of a LDNS\_RR\_TYPE\_RRSIG RR .br **r**: the resource record .br Returns a ldns\_rdf\* with the expiration time or NULL on failure

*ldns\_rr\_rrsig\_set\_expiration*() sets the expiration date of a LDNS\_RR\_TYPE\_RRSIG rr .br **r**: the rr to use .br **f**: the expiration date to set .br Returns true on success, false otherwise

*ldns\_rr\_rrsig\_inception*() returns the inception time of a LDNS\_RR\_TYPE\_RRSIG RR .br **r**: the resource record .br Returns a ldns\_rdf\* with the inception time or NULL on failure

*ldns\_rr\_rrsig\_set\_inception*() sets the inception date of a LDNS\_RR\_TYPE\_RRSIG rr .br **r**: the rr to use .br **f**: the inception date to set .br Returns true on success, false otherwise

*ldns\_rr\_rrsig\_keytag*() returns the keytag of a LDNS\_RR\_TYPE\_RRSIG RR .br **r**: the resource record .br Returns a ldns\_rdf\* with the keytag or NULL on failure

*ldns\_rr\_rrsig\_set\_keytag*() sets the keytag of a LDNS\_RR\_TYPE\_RRSIG rr .br **r**: the rr to use .br **f**: the keytag to set .br Returns true on success, false otherwise

*ldns\_rr\_rrsig\_signame*() returns the signers name of a LDNS\_RR\_TYPE\_RRSIG RR .br **r**: the resource record .br Returns a ldns\_rdf\* with the signers name or NULL on failure

*ldns\_rr\_rrsig\_set\_signame*() sets the signers name of a LDNS\_RR\_TYPE\_RRSIG rr .br **r**: the rr to use .br **f**: the signers name to set .br Returns true on success, false otherwise

*ldns\_rr\_rrsig\_sig*() returns the signature data of a LDNS\_RR\_TYPE\_RRSIG RR .br **r**: the resource record .br Returns a ldns\_rdf\* with the signature data or NULL on failure

*ldns\_rr\_rrsig\_set\_sig*() sets the signature data of a LDNS\_RR\_TYPE\_RRSIG rr .br **r**: the rr to use .br **f**: the signature data to set .br Returns true on success, false otherwise

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
