---
name: "ldns_rr_mx_preference"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_rr_mx_preference"
---

# ldns\_rr\_mx\_preference(3)

get MX RR rdata fields

## NAME

ldns\_rr\_mx\_preference, ldns\_rr\_mx\_exchange - get MX RR rdata fields

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_rdf\* ldns\_rr\_mx\_preference(const ldns\_rr \*r);

ldns\_rdf\* ldns\_rr\_mx\_exchange(const ldns\_rr \*r);

## DESCRIPTION

*ldns\_rr\_mx\_preference*() returns the mx pref. of a LDNS\_RR\_TYPE\_MX rr .br **r**: the resource record .br Returns a ldns\_rdf\* with the preference or NULL on failure

*ldns\_rr\_mx\_exchange*() returns the mx host of a LDNS\_RR\_TYPE\_MX rr .br **r**: the resource record .br Returns a ldns\_rdf\* with the name of the MX host or NULL on failure

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

**perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034** and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
