---
name: "ldns_rr_list_sort"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_rr_list_sort"
---

# ldns\_rr\_list\_sort(3)

sort a ldns\_rr\_list

## NAME

ldns\_rr\_list\_sort - sort a ldns\_rr\_list

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

void ldns\_rr\_list\_sort(ldns\_rr\_list \*unsorted);

## DESCRIPTION

*ldns\_rr\_list\_sort*() sorts an rr\_list (canonical wire format). the sorting is done inband. .br **unsorted**: the rr\_list to be sorted .br Returns void

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
