---
name: "ldns_rr_list_set_rr_count"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_rr_list_set_rr_count"
---

# ldns\_rr\_list\_set\_rr\_count(3)

get and set ldns\_rr\_list length

## NAME

ldns\_rr\_list\_rr\_count, ldns\_rr\_list\_set\_rr\_count - get and set ldns\_rr\_list length

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

size\_t ldns\_rr\_list\_rr\_count(const ldns\_rr\_list \*rr\_list);

void ldns\_rr\_list\_set\_rr\_count(ldns\_rr\_list \*rr\_list, size\_t count);

## DESCRIPTION

*ldns\_rr\_list\_rr\_count*() returns the number of rr's in an rr\_list. .br **rr\_list**: the rr\_list to read from .br Returns the number of rr's

*ldns\_rr\_list\_set\_rr\_count*() sets the number of rr's in an rr\_list. .br **rr\_list**: the rr\_list to set the count on .br **count**: the number of rr in this list .br Returns void

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
