---
name: "ldns_rr_list_print"
section: "3"
platform: "linux"
package: "libldns-dev"
version: "1.6.17-5+b1"
release: "Debian 8 (Jessie)"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_rr_list_print"
---

# ldns\_rr\_list\_print(3)

## NAME

ldns\_rr\_print, ldns\_rdf\_print, ldns\_pkt\_print, ldns\_rr\_list\_print, ldns\_resolver\_print, ldns\_zone\_print-

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

void ldns\_rr\_print(FILE \*output, const ldns\_rr \*rr);

void ldns\_rdf\_print(FILE \*output, const ldns\_rdf \*rdf);

void ldns\_pkt\_print(FILE \*output, const ldns\_pkt \*pkt);

void ldns\_rr\_list\_print(FILE \*output, const ldns\_rr\_list \*list);

void ldns\_resolver\_print(FILE \*output, const ldns\_resolver \*r);

void ldns\_zone\_print(FILE \*output, const ldns\_zone \*z);

## DESCRIPTION

*ldns\_rr\_print*() Prints the data in the resource record to the given file stream (in presentation format)

.br **output**: the file stream to print to .br **rr**: the resource record to print .br Returns void

*ldns\_rdf\_print*() Prints the data in the rdata field to the given file stream (in presentation format)

.br **output**: the file stream to print to .br **rdf**: the rdata field to print .br Returns void

*ldns\_pkt\_print*() Prints the data in the DNS packet to the given file stream (in presentation format)

.br **output**: the file stream to print to .br **pkt**: the packet to print .br Returns void

*ldns\_rr\_list\_print*() print a rr\_list to output .br **output**: the fd to print to .br **list**: the rr\_list to print

*ldns\_resolver\_print*() Print a resolver (in sofar that is possible) state to output. .br **output**: the fd to print to .br **r**: the resolver to print

*ldns\_zone\_print*() Print a zone structure \* to output. Note the SOA record is included in this output .br **output**: the fd to print to .br **z**: the zone to print

## AUTHOR

The ldns team at NLnet Labs. Which consists out of Jelte Jansen and Miek Gieben.

## REPORTING BUGS

Please report bugs to ldns-team@nlnetlabs.nl or in  our bugzilla at http://www.nlnetlabs.nl/bugs/index.html

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_rr2str*, *ldns\_rdf2str*, *ldns\_pkt2str*, *ldns\_rr\_list2str*, *ldns\_key2str*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automaticly generated from the ldns source code by use of Doxygen and some perl.
