---
name: "ldns_rr_list_pop_rr"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_rr_list_pop_rr"
---

# ldns\_rr\_list\_pop\_rr(3)

ldns\_rr\_list manipulation

## NAME

ldns\_rr\_list\_cat, ldns\_rr\_list\_push\_rr, ldns\_rr\_list\_pop\_rr - ldns\_rr\_list manipulation

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

bool ldns\_rr\_list\_cat(ldns\_rr\_list \*left, const ldns\_rr\_list \*right);

bool ldns\_rr\_list\_push\_rr(ldns\_rr\_list \*rr\_list, const ldns\_rr \*rr);

ldns\_rr\* ldns\_rr\_list\_pop\_rr(ldns\_rr\_list \*rr\_list);

## DESCRIPTION

*ldns\_rr\_list\_cat*() concatenates two ldns\_rr\_lists together. This modifies \*left (to extend it and add the pointers from \*right). .br **left**: the leftside .br **right**: the rightside .br Returns a left with right concatenated to it

*ldns\_rr\_list\_push\_rr*() pushes an rr to an rrlist. .br **rr\_list**: the rr\_list to push to  .br **rr**: the rr to push  .br Returns false on error, otherwise true

*ldns\_rr\_list\_pop\_rr*() pops the last rr from an rrlist. .br **rr\_list**: the rr\_list to pop from .br Returns NULL if nothing to pop. Otherwise the popped RR

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
