---
name: "ldns_rr_list_clone"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_rr_list_clone"
---

# ldns\_rr\_list\_clone(3)

clone a ldns\_rr\_list

## NAME

ldns\_rr\_list\_clone - clone a ldns\_rr\_list

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_rr\_list\* ldns\_rr\_list\_clone(const ldns\_rr\_list \*rrlist);

## DESCRIPTION

*ldns\_rr\_list\_clone*() clones an rrlist. .br **rrlist**: the rrlist to clone .br Returns the cloned rr list

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
