---
name: "ldns_rr_get_class"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_rr_get_class"
---

# ldns\_rr\_get\_class(3)

access rdata fields on ldns\_rr

## NAME

ldns\_rr\_rdf, ldns\_rr\_owner, ldns\_rr\_rd\_count, ldns\_rr\_ttl, ldns\_rr\_get\_class - access rdata fields on ldns\_rr

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_rdf\* ldns\_rr\_rdf(const ldns\_rr \*rr, size\_t nr);

ldns\_rdf\* ldns\_rr\_owner(const ldns\_rr \*rr);

size\_t ldns\_rr\_rd\_count(const ldns\_rr \*rr);

uint32\_t ldns\_rr\_ttl(const ldns\_rr \*rr);

ldns\_rr\_class ldns\_rr\_get\_class(const ldns\_rr \*rr);

## DESCRIPTION

*ldns\_rr\_rdf*() returns the rdata field member counter. .br **\*rr**: rr to operate on .br **nr**: the number of the rdf to return .br Returns ldns\_rdf \*

*ldns\_rr\_owner*() returns the owner name of an rr structure. .br **\*rr**: rr to operate on .br Returns ldns\_rdf \*

*ldns\_rr\_rd\_count*() returns the rd\_count of an rr structure. .br **\*rr**: the rr to read from .br Returns the rd count of the rr

*ldns\_rr\_ttl*() returns the ttl of an rr structure. .br **\*rr**: the rr to read from .br Returns the ttl of the rr

*ldns\_rr\_get\_class*() returns the class of the rr. .br **\*rr**: the rr to read from .br Returns the class of the rr

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_rr*, *ldns\_rr\_list*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
