---
name: "ldns_rr_descriptor_maximum"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_rr_descriptor_maximum"
---

# ldns\_rr\_descriptor\_maximum(3)

rdata field descriptors

## NAME

ldns\_rr\_descriptor, ldns\_rr\_descript, ldns\_rr\_descriptor\_minimum, ldns\_rr\_descriptor\_maximum, ldns\_rr\_descriptor\_field\_type - rdata field descriptors

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

const ldns\_rr\_descriptor\* ldns\_rr\_descript(uint16\_t type);

size\_t ldns\_rr\_descriptor\_minimum(const ldns\_rr\_descriptor \*descriptor);

size\_t ldns\_rr\_descriptor\_maximum(const ldns\_rr\_descriptor \*descriptor);

ldns\_rdf\_type ldns\_rr\_descriptor\_field\_type(const ldns\_rr\_descriptor \*descriptor, size\_t field);

## DESCRIPTION

*ldns\_rr\_descriptor*\
 Contains all information about resource record types.\

This structure contains, for all rr types, the rdata fields that are defined.\
 struct ldns\_struct\_rr\_descriptor\
 {\
\
 	**Type of the RR that is described here:**\
\
 	ldns\_rr\_type    \_type;\
\
 	**Textual name of the RR type.:**\
\
 	const char \*\_name;\
\
 	**Minimum number of rdata fields in the RRs of this type.:**\
\
 	uint8\_t     \_minimum;\
\
 	**Maximum number of rdata fields in the RRs of this type.:**\
\
 	uint8\_t     \_maximum;\
\
 	**Wireformat specification for the rr, i.e. the types of rdata fields in their respective order.:**\
\
 	const ldns\_rdf\_type \*\_wireformat;\
\
 	**Special rdf types:**\
\
 	ldns\_rdf\_type \_variable;\
\
 	**Specifies whether compression can be used for dnames in this RR type.:**\
\
 	ldns\_rr\_compress \_compress;\
\
 	**The number of DNAMEs in the \_wireformat string, for parsing.:**\
\
 	uint8\_t \_dname\_count;\
 };\
 typedef struct ldns\_struct\_rr\_descriptor ldns\_rr\_descriptor;

*ldns\_rr\_descript*() returns the resource record descriptor for the given rr type.

.br **type**: the type value of the rr type .br Returns the ldns\_rr\_descriptor for this type

*ldns\_rr\_descriptor\_minimum*() returns the minimum number of rdata fields of the rr type this descriptor describes.

.br **descriptor**: for an rr type .br Returns the minimum number of rdata fields

*ldns\_rr\_descriptor\_maximum*() returns the maximum number of rdata fields of the rr type this descriptor describes.

.br **descriptor**: for an rr type .br Returns the maximum number of rdata fields

*ldns\_rr\_descriptor\_field\_type*() returns the rdf type for the given rdata field number of the rr type for the given descriptor.

.br **descriptor**: for an rr type .br **field**: the field number .br Returns the rdf type for the field

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_rr*, *ldns\_rdf*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
