NAME
ldns_rr_compare, ldns_rr_compare_ds - compare a ldns_rr
SYNOPSIS
#include <stdint.h>
#include <stdbool.h>
#include <ldns/ldns.h>
int ldns_rr_compare(const ldns_rr *rr1, const ldns_rr *rr2);
bool ldns_rr_compare_ds(const ldns_rr *rr1, const ldns_rr *rr2);
DESCRIPTION
ldns_rr_compare() compares two rrs. The TTL is not looked at. .br rr1: the first one .br rr2: the second one .br Returns 0 if equal -1 if rr1 comes before rr2 +1 if rr2 comes before rr1
ldns_rr_compare_ds() returns true of the given rr's are equal. Also returns true if one record is a DS that represents the same DNSKEY record as the other record .br rr1: the first rr .br rr2: the second rr .br Returns true if equal otherwise false
AUTHOR
The ldns team at NLnet Labs.
REPORTING BUGS
Please report bugs to [email protected] or on GitHub at https://github.com/NLnetLabs/ldns/issues
COPYRIGHT
Copyright (c) 2004 - 2006 NLnet Labs.
Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
SEE ALSO
ldns_rr, ldns_rr_list. And perldoc Net::DNS, RFC1034, RFC1035, RFC4033, RFC4034 and RFC4035.
REMARKS
This manpage was automatically generated from the ldns source code.