---
name: "ldns_rr2wire"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_rr2wire"
---

# ldns\_rr2wire(3)

conversion functions

## NAME

ldns\_rr2wire, ldns\_pkt2wire, ldns\_rdf2wire - conversion functions

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_status ldns\_rr2wire(uint8\_t \*\*dest, const ldns\_rr \*rr, int section, size\_t \*size);

ldns\_status ldns\_pkt2wire(uint8\_t \*\*dest, const ldns\_pkt \*p, size\_t \*size);

ldns\_status ldns\_rdf2wire(uint8\_t \*\*dest, const ldns\_rdf \*rdf, size\_t \*size);

## DESCRIPTION

*ldns\_rr2wire*() Allocates an array of uint8\_t at dest, and puts the wireformat of the given rr in that array. The result\_size value contains the length of the array, if it succeeds, and 0 otherwise (in which case the function also returns NULL)

If the section argument is LDNS\_SECTION\_QUESTION, data like ttl and rdata are not put into the result

.br **dest**: pointer to the array of bytes to be created .br **rr**: the rr to convert .br **section**: the rr section, determines how the rr is written. .br **size**: the size of the converted result

*ldns\_pkt2wire*() Allocates an array of uint8\_t at dest, and puts the wireformat of the given packet in that array. The result\_size value contains the length of the array, if it succeeds, and 0 otherwise (in which case the function also returns NULL)

.br **dest**: pointer to the array of bytes to be created .br **p**: the packet to convert .br **size**: the size of the converted result

*ldns\_rdf2wire*() Allocates an array of uint8\_t at dest, and puts the wireformat of the given rdf in that array. The result\_size value contains the length of the array, if it succeeds, and 0 otherwise (in which case the function also returns NULL)

.br **dest**: pointer to the array of bytes to be created .br **rdf**: the rdata field to convert .br **size**: the size of the converted result

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_wire2rr*, *ldns\_wire2pkt*, *ldns\_wire2rdf*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
