---
name: "ldns_rdf_set_data"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_rdf_set_data"
---

# ldns\_rdf\_set\_data(3)

set rdf attributes

## NAME

ldns\_rdf\_set\_size, ldns\_rdf\_set\_type, ldns\_rdf\_set\_data - set rdf attributes

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

void ldns\_rdf\_set\_size(ldns\_rdf \*rd, size\_t size);

void ldns\_rdf\_set\_type(ldns\_rdf \*rd, ldns\_rdf\_type type);

void ldns\_rdf\_set\_data(ldns\_rdf \*rd, void \*data);

## DESCRIPTION

*ldns\_rdf\_set\_size*() sets the size of the rdf. .br **\*rd**: the rdf to operate on .br **size**: the new size .br Returns void

*ldns\_rdf\_set\_type*() sets the size of the rdf. .br **\*rd**: the rdf to operate on .br **type**: the new type .br Returns void

*ldns\_rdf\_set\_data*() sets the size of the rdf. .br **\*rd**: the rdf to operate on .br **\*data**: pointer to the new data .br Returns void

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_rdf*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
