---
name: "ldns_rdf_data"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_rdf_data"
---

# ldns\_rdf\_data(3)

get rdf attributes

## NAME

ldns\_rdf\_size, ldns\_rdf\_get\_type, ldns\_rdf\_data, ldns\_rdf\_compare - get rdf attributes

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

size\_t ldns\_rdf\_size(const ldns\_rdf \*rd);

ldns\_rdf\_type ldns\_rdf\_get\_type(const ldns\_rdf \*rd);

uint8\_t\* ldns\_rdf\_data(const ldns\_rdf \*rd);

int ldns\_rdf\_compare(const ldns\_rdf \*rd1, const ldns\_rdf \*rd2);

## DESCRIPTION

*ldns\_rdf\_size*() returns the size of the rdf. .br **\*rd**: the rdf to read from .br Returns uint16\_t with the size

*ldns\_rdf\_get\_type*() returns the type of the rdf. We need to insert \_get\_ here to prevent conflict the rdf\_type TYPE. .br **\*rd**: the rdf to read from .br Returns ldns\_rdf\_type with the type

*ldns\_rdf\_data*() returns the data of the rdf. .br **\*rd**: the rdf to read from

.br Returns uint8\_t\* pointer to the rdf's data

*ldns\_rdf\_compare*() compares two rdf's on their wire formats. (To order dnames according to rfc4034, use ldns\_dname\_compare) .br **rd1**: the first one .br **rd2**: the second one .br Returns 0 if equal .br Returns -1 if rd1 comes before rd2 .br Returns +1 if rd2 comes before rd1

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_rdf*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
