---
name: "ldns_rdf_address_reverse"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_rdf_address_reverse"
---

# ldns\_rdf\_address\_reverse(3)

reverse an address rdf

## NAME

ldns\_rdf\_address\_reverse - reverse an address rdf

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_rdf\* ldns\_rdf\_address\_reverse(const ldns\_rdf \*rd);

## DESCRIPTION

*ldns\_rdf\_address\_reverse*() reverses an rdf, only actually useful for AAAA and A records. The returned rdf has the type LDNS\_RDF\_TYPE\_DNAME! .br **\*rd**: rdf to be reversed .br Returns the reversed rdf (a newly created rdf)

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_rdf*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
