---
name: "ldns_pkt_verify"
section: "3"
platform: "linux"
package: "ldns"
version: "1.9.2-1"
release: "Arch Linux 2026-11-01"
platforms: ["linux"]
url: "https://new.carta.tech/ldns_pkt_verify"
---

# ldns\_pkt\_verify(3)

verify a packet

## NAME

ldns\_pkt\_verify - verify a packet

## SYNOPSIS

\#include \<stdint.h\>\
 \#include \<stdbool.h\>\

\#include \<ldns/ldns.h\>

ldns\_status ldns\_pkt\_verify(const ldns\_pkt \*p, ldns\_rr\_type t, const ldns\_rdf \*o, const ldns\_rr\_list \*k, const ldns\_rr\_list \*s, ldns\_rr\_list \*good\_keys);

## DESCRIPTION

*ldns\_pkt\_verify*() verify a packet  .br **p**: the packet .br **t**: the rr set type to check .br **o**: the rr set name to check .br **k**: list of keys .br **s**: list of sigs (may be null) .br **good\_keys**: keys which validated the packet .br Returns status

## AUTHOR

The ldns team at NLnet Labs.

## REPORTING BUGS

Please report bugs to dns-team@nlnetlabs.nl or on GitHub at https://github.com/NLnetLabs/ldns/issues

## COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

## SEE ALSO

*ldns\_verify*, *ldns\_sign\_public*, *ldns\_zone\_sign*. And **perldoc Net::DNS**, **RFC1034**, **RFC1035**, **RFC4033**, **RFC4034**  and **RFC4035**.

## REMARKS

This manpage was automatically generated from the ldns source code.
