Reference

ldns_pkt_verify(3)

verify a packet

NAME

ldns_pkt_verify - verify a packet

SYNOPSIS

#include <stdint.h>
#include <stdbool.h>

#include <ldns/ldns.h>

ldns_status ldns_pkt_verify(const ldns_pkt *p, ldns_rr_type t, const ldns_rdf *o, const ldns_rr_list *k, const ldns_rr_list *s, ldns_rr_list *good_keys);

DESCRIPTION

ldns_pkt_verify() verify a packet .br p: the packet .br t: the rr set type to check .br o: the rr set name to check .br k: list of keys .br s: list of sigs (may be null) .br good_keys: keys which validated the packet .br Returns status

AUTHOR

The ldns team at NLnet Labs.

REPORTING BUGS

Please report bugs to [email protected] or on GitHub at https://github.com/NLnetLabs/ldns/issues

COPYRIGHT

Copyright (c) 2004 - 2006 NLnet Labs.

Licensed under the BSD License. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

SEE ALSO

ldns_verify, ldns_sign_public, ldns_zone_sign. And perldoc Net::DNS, RFC1034, RFC1035, RFC4033, RFC4034 and RFC4035.

REMARKS

This manpage was automatically generated from the ldns source code.

History